0

I have set up autologin by editing /etc/inittab, changing the line

1:2345:respawn:/sbin/getty --noclear 38400 tty1

to

1:2345:respawn:/sbin/getty --autologin pi --noclear 38400 tty1

This works fine. I have now installed Upstart to run and respawn some Python scripts on boot, however the device no longer boots to the terminal screen but instead prompts for a username/password.

I'm using the 2014-01-07-wheezy-raspbian.img image.

1

Upstart replaces the traditionally init system, which means that the /etc/inittab file is now effectively ignored, ignoring your change. All is not lost. Upstart also allows automatic logins. It's simply a matter of working out which configuration file. Information on this seems to be a bit sketchy (and I don't have an Upstart enabled system to test with), but it looks like you can edit the /etc/init/tty1.conf file to add the --autologin pi bit, so you end up with something like this in the file:

exec /sbin/getty --autologin pi --noclear 38400 tty1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.