0

I have my Raspberry Pi connected to my Mac via ethernet, I can ssh into it fine. But when I turn internet sharing on, the connection is cut and I can no longer ping the Raspberry Pi's IP. I've tried restarting the ethernet connection but I still get nothing.

  • My raspberry Pi (running Raspbian) has the IP address: 169.254.0.2

  • DHCP sets my Mac's IP address: 169.254.3.74 With subnet: 255.255.0.0

  • The IP address on my wifi connection is: 192.168.0.4

Can anyone enlighten me as to what's going on here?

Thanks in advance,

Ryan

3
  • Q1: The raspberry Pi IP address, is it set by DHCP or do you assign it manually? Q2: Is it correct to presume these are the IP addresses after you have turned on Internet sharing? Mar 23, 2014 at 14:57
  • Yes, DHCP sets the IP addresses. I've tried setting it manually also though. And yes they are. Mar 26, 2014 at 21:22
  • I don't believe that there is a DHCP server on your ethernet subnet because 169.254.0.0/16 are self assigned ip addresses. If they are really come from a DHCP server then there is a missconfiguration.
    – Ingo
    May 17, 2018 at 8:26

1 Answer 1

0

The following way works for me: First I connected my mac to the Internet via wifi Then on system preferences> Network> Ethernet : Manually assigned an IP Addr, Mine is : 192.168.2.1, Subnet mask: 255.255.255.0, DNS: any free DNS servers like : 8.8.8.8 and router should be remained blank Then on system preferences> Sharing , I marked Internet sharing, chose "share your connection from" as "WiFi" and "Ports" on "Ethernet" Now plug your ethernet cable to the raspberry pi, and configure its connection like: IP Addr: 192.168.2.2 (the same range address of the ethernet port of your mac) subnet mask: 255.255.255.0 Router: 192.168.2.1 DNS: 8.8.8.8

Then reboot your raspberry. Now it should be connected to the Internet

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.