I flashed a clean 4GB SD card with raspbmc, and ran it on my Pi. It progresses through the installer but gets stuck in a reboot loop:

'R' screen -> "Relax, XBMC will resume shortly..." -> Blue "Updating XBMC" -> 'R' screen -> etc...

Pulling the power doesn't help, it reverts back to this cycle, except instead of the blue "Updating XBMC" screen there's a few lines of text, ending with "Mounting local filesystems: failed". Pressing esc to get to the terminal gets me to a black screen, I can't type at all. Nothing is connected to the Pi apart from a USB keyboard. I've reflashed the card twice, and the same thing happens. What's going on?

  • 1
    Have you tried another card? Aug 6, 2012 at 19:02
  • @SteveRobillard No other cards on hand at the moment, but up until recently I was running raspbian off this card fine (and I did a total erase of the card before installing RaspBMC)
    – Tom Medley
    Aug 6, 2012 at 19:03
  • I am having the exact same problem. I am using a Patriot LX 8gb series 10 card and have used it to run Raspbian and OpenElec with no problems. I am currently loading the prebuilt image from here: juicypi.com/downloads/RC4+Addons.rar Hopefully I'll have more luck with that.
    – user1026
    Aug 6, 2012 at 19:37
  • Let me know how you get on! I'm frustrated by how impenetrable this problem seems to be!
    – Tom Medley
    Aug 6, 2012 at 19:39
  • Seeing as 3 people on this site have reported issues with Raspbmc I was going to recommend trying the older (possibly more stable) RC3 rather than RC4, but when I went to find a link the Raspbmc site was down.
    – Dan B
    Aug 6, 2012 at 20:09

4 Answers 4


I experienced the same problem. I think the trigger of the reboot chain was an apt-get upgrade, though I'm not 100% sure. The only thing I tried was re flashing the SD, which helped till I finished to configure the system (installed samba, auto mounting devices etc). In my current image I avoided the upgrade and it runs fine up to now.

  • Just did the same. XBMC was running fine (except my Airplay wasn't working) then I decided to sudo apt-get update and sudo apt-get upgrade and BOOM reboot loop!
    – Joe
    Sep 30, 2012 at 16:53
  • my SSH stoped working as well. is there anyway to abort XBMC from boot? Oct 13, 2012 at 8:37

Finally got to the bottom of this: it was a dodgy power adapter. Replacing the power adapter seems to have fixed the problem!

  • This was my problem as well. My RPi B+ had worked just fine for weeks but suddenly got stuck in a boot loop (the raspberry logo showed up for a second, reboot, repeat) when I tried to power it via a USB extension cable. Sep 15, 2014 at 10:33
  • My problem was close: a dodgy USB cable... Oct 1, 2015 at 14:46

Not a great solution, but you can get the RPi to boot by disconnecting the ethernet cable while booting (preventing it from trying to update) and plugging it back in when it's up and running.

  • Does the rebooting continue once updated? Aug 13, 2012 at 9:16
  • @AlexChamberlain It doesn't update (since I unplug the ethernet cable to allow it to boot). If I reboot using sudo reboot -f I get stuck in the same loop though, and need to perform the same trick.
    – Tom Medley
    Aug 13, 2012 at 9:18

I had a similar reboot loop issue with a 4Gb sdcard and have now got it working after a reflash. The only things I changed were that I wiped and reformatted the card with an NTFS format instead of FAT before running install.py (I wondered if 4Gb was the issue) and then I also had direct ethernet cable plugged in before booting up the first time (I had no screen so am not sure whether it installed correctly).

It may have run without an internet connection the first time I tried.

  • 2
    This answer is misleading - you don't need to partition the SD Card before flashing the image. Aug 13, 2012 at 12:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.