0

I used the official imager to set up localization and networking and install its "recommended OS" (32-bit bullseye) on a Raspberry Pi Zero W. It comes up to a desktop where the network icon in the top panel shows red X X.

I got a shell and rfkill list all shows nothing blocked.
ip addr show shows lo is okay but wlan0 has NO-CARRIER. iwlist scanning shows lots of detail about the six closest hotspots. wpa_supplicant.conf is identical to one on a R-pi model 3B+ that works fine. The DHCP log on the hotspot ( a 3B+ running hostapd and isc-dhcp-server ) shows no broadcast received. It seems the wifi chip can receive but it can't send. Wired Ethernet is fine.

During boot, kernel throws this error:

Mar 11 15:10:32 pepper kernel: cfg80211: Loading compiled-in X.509 certificates for regulatory database
Mar 11 15:10:32 pepper kernel: cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
Mar 11 15:10:32 pepper kernel: cfg80211: loaded regulatory.db is malformed or signature is missing/invalid

This same board had no problem getting on wifi before bullseye. What's going on here? It seems the foundation has dropped support for the Pi Zero W.

This question is similar: Is WiFi of my Raspberry Pi Zero W broken? Nobody answered.

5
  • Have you set your WiFi country code?
    – CoderMike
    Commented Mar 14 at 23:53
  • 1
    Wired Ethernet is fine on a Pi Zero? Commented Mar 15 at 0:13
  • Your question is indeed similar to the link - (which incidentally has an accepted answer). Both are nonsense and contain no meaningful information.
    – Milliways
    Commented Mar 15 at 11:10
  • The Raspberry Pi Foundation's Imager sets the wifi country code. When I got a shell I ran raspi-config and it had already been set correctly. wpa_supplicant,conf already had the essid and passphrase. The wired Ethernet is connected through a 10/100 USB dongle and an unpowered four port USB3 hub. The hub also has a wireless keyboard transceiver and a "charger doctor" voltmeter (reading 5.03 volts) plugged into it. So, yes, wired ethernet works just fine on an R-Pi Zero. Commented Mar 16 at 3:19
  • Of course I tried the solution in the accepted answer on the other question. No change. dhcpcd is running and it obtained its address from DHCP on the router. This is not the same issue as the one in the other question. Commented Mar 16 at 3:39

1 Answer 1

0

It turns out that the default radio settings on the Raspberry Pi 3B that I am using for an Access Point are not compatible with the default settings on the Zero W.

On the AP, wmm is enabled by default in /etc/hostapd/hostapd.conf. The setting is not shown in the config file that comes with hostapd. I added a line

wmm_enabled=0

at the end of that file and rebooted the AP. Communications with the Zero W is restored. Both bullseye (dhcpcd) and bookworm (NetworkManager) work now. No change was required on the Zero W.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.