0

I would install php (php-fpm) on my raspberry pi 3 b+. Its running with raspbian stretch 9 i dont have choice, i must keep this version. I can’t even update, the official mirrors that are programmed to be used no longer work on Stretch and earlier.

How Can i install it with a USB key?

I dont know if its Can help but nginx is installed. I want php because i need to execute a script to shutdown the raspberry from an interface (which is a HTML page, that i Can access from my phone connected from wifi raspberry). Ive tried flask but i cant install it with pip.

Thanks for reading and excuse my english

5
  • Why can’t you change from Stretch?
    – CoderMike
    Mar 17 at 20:29
  • Because the IMG ive downloaded is build with Stretch, the author doesnt have the time to update it and i dont have the skills to do it myself :( its an old img
    – Yoo
    Mar 17 at 21:03
  • What is this img?
    – CoderMike
    Mar 17 at 23:40
  • A live lightpainting application oliver-mayer.com/work_f1uxu5.html and github github.com/0may/f1uxu5
    – Yoo
    Mar 18 at 0:54
  • DO NOT put detail in Comments; EDIT your Question.
    – Milliways
    Mar 18 at 7:09

1 Answer 1

0

The old raspbian have been moved to legacy (Stretch on 17-Aug-2023) but haven't been updated for years (and never will).
The old mirrors no longer exist.

Try deb http://legacy.raspbian.org/raspbian/ stretch main contrib in /etc/apt/sources.list or /etc/apt/sources.list.d


This should work but custom OS may differ.

Frankly custom OS are a bad idea - if the author of a program doesn't offer a version installable on a standard OS (preferably with source) I would give it a miss.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.