1

I just configured a Squeezeplug RP using a Vantec HX4R, 4-disk RAID array with an ext3 file system, connected through a Pluggable 7-port powered USB hub. The HX4R has its own power supply. It configured fine, Squeezeplug scanned the 500 GB of music that I'd put on it and served music all evening. I shut it down and the next time I started it, the disk array was not recognized. No device for it in /dev. After trying various startup sequences and trying to go through the initial config again there was no change. Finally I tried plugging the array's USB cable directly into the remaining open port on the Pi and it showed up in /dev right away. I did a manual mount and it's serving music again. Most people seem to have issues with power that require moving the disk drive to a powered hub. This time the drive has to be connected directly to the Pi.

It seems that the Vantec HX4R hardware-RAID array is not compatible with the Pluggable USB2-HUB-AG7 USB hub. I'd forgotten that the hub has an LED for each port that lights when the port is active. Plugging the cable from the HX4R into a port on the hub does not light the LED and the drives spin down just as when it's not plugged into anything. The HX4R is USB 3.0, but it's compatible with USB 2.0. As stated above, it works directly plugged in the RP.

Update: I found a port on the hub that works! If I waste more time checking them, I wonder if I'll find others. Thanks for the inside dope on "7-port" hubs. Maybe I should test it to know which ports to tape over....

  • Did you try all 7 ports on the hub ? Most 7 port hubs are 2 4-port hubs daisy chained together and can cause issues with some devices. – Lawrence Mar 26 '14 at 4:54
  • Thanks, @Lawrence. That makes sense. I probably used a different port the first time I ran it. I haven't time to test your hypothesis, but I'll report back when I do. – user13745 Mar 27 '14 at 5:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.