-1

today when I tried to update the pi os it gave me an error. I downloaded Kodi and Retro Pie yesterday. Before that I did the update without any errors. And now it gives me this error:enter image description here

And in the terminal it tells me that two upgrades are not installed.

I hope you can help me as I am new to this. Thanks in advance!

9
  • Try running sudo apt upgrade && sudo apt full-upgrade
    – Dirk
    Apr 2 at 15:28
  • Also - please try not to post screenshots of your terminal.
    – Seamus
    Apr 2 at 16:52
  • @Dirk When I type the command sudo apt upgrade it just says 2 not upgrade. And sudo apt full-upgrade installed something, but for the update it throws the same error and in the terminal it still says 2 not upgraded when I do sudo apt upgrade.
    – Škeble
    Apr 2 at 20:35
  • You have tagged this with rpi-update. If you have run this (and ignored the warning) you have probably corrupted your OS.
    – Milliways
    Apr 2 at 21:59
  • 1
    Thank you all for your help, but I was able to solve the problem myself. I deleted libsdl2-dev with "sudo apt-get remove --auto-remove libsdl2-dev" and reinstalled with "sudo apt-get install libsdl2-dev".
    – Škeble
    Apr 5 at 15:24

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.