0

I've read that some of the necessary pipewire modules for bullseye are available through the backports repo. I tried this, but had problems as described below:

Add following line to /etc/apt/sources.list :

deb http://deb.debian.org/debian bullseye-backports main contrib non-free 

# then run: 

sudo apt update
Get:1 http://deb.debian.org/debian bullseye-backports InRelease [49.0 kB]
Hit:2 http://archive.raspberrypi.org/debian bullseye InRelease
Err:1 http://deb.debian.org/debian bullseye-backports InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0E98404D386FA1D9 NO_PUBKEY 6ED0E7B82643E131
Hit:3 http://raspbian.raspberrypi.org/raspbian bullseye InRelease
Reading package lists... Done
W: GPG error: http://deb.debian.org/debian bullseye-backports InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 0E98404D386FA1D9 NO_PUBKEY 6ED0E7B82643E131
E: The repository 'http://deb.debian.org/debian bullseye-backports InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

What's going on here? Can anyone help?

7
  • 1
    I had this "public key is not available..can't be done securely..therefore disabled" problem recently on a new (64-bit) bookworm install, having made no changes to sources.list or any other apt config. Happened spontaneously after a few boots, and wouldn't install anything. I spent a fair bit of time researching it before giving up and re-installing (the problem I think caused by corruption as two Amazon Basics SD cards proved unusable, eventually would end up in emergency mode unable to mount, although they looked fine in another linux box). Drill down on the GPG issue if you get desperate.
    – goldilocks
    Apr 6 at 15:35
  • Raspbian is a 32bit OS for ARM6 code (although later models of Pi use ARM7 kernels). Debian does not (and AFAIK never has) supported ARM6 so Debian code is unlikely to work and may depend on ARM7 instructions in libraries. If you used a 64 bit OS it may work.
    – Milliways
    Apr 6 at 22:04
  • @Milliways: see answer below
    – Seamus
    Apr 6 at 22:54
  • @Seamus Incidentally have you tried 64 bit? I had avoided (like the Foundation or whatever it calls itself today) but pre Bookworm release I updated a Lite install to Bookworm for testing which worked flawlessly (unlike the full version). I noticed no differences in performance, maybe a tiny bit larger apps and you get to use Debian tested code (except for Pi specific code like kernel etc). I have since installed the Lite release on my Pi3A Bookworm has 0.3.65-3+rpt6+deb12u1 version of pipewire.
    – Milliways
    Apr 7 at 0:34
  • 1
    I'm thinking of booting it from a USB thumb drive for the first time, lol. Those speeds are fine for my purposes; they're enough to allow streaming video without compromising the system otherwise, and most of the mass transfers I do are automated backups via the internet, which are bottlenecked by the network speed anyway (even with a short cat8 cable in a direct link to my desktop I've never seen them get halfway close to gigabit speed).
    – goldilocks
    Apr 11 at 15:38

1 Answer 1

2

I think I've resolved this - thanks to @goldilocks' Comment. For anyone else suffering from the "Raspberry Rash", here's what to do:

1. Note first that the URL indicates this is a Debian repo - NOT a raspberrypi URL. Thus, the need for a different GPG key! (silly me)

2. Therefore, we must get and install the Debian GPG key; accomplished as follows:

# download the Debian key:  

$ curl -O http://http.us.debian.org/debian/pool/main/d/debian-archive-keyring/debian-archive-keyring_2023.4_all.deb 

# install the Debian key:

$ sudo dpkg -i debian-archive-keyring_2023.4_all.deb  

Selecting previously unselected package debian-archive-keyring.
(Reading database ... 114968 files and directories currently installed.)
Preparing to unpack debian-archive-keyring_2023.4_all.deb ...
Unpacking debian-archive-keyring (2023.4) ...
Setting up debian-archive-keyring (2023.4) ... 

3. And you can now update & install the pipewire upgrade from bullseye-backports:

$ sudo apt update

...

$ sudo apt install -t bullseye-backports pipewire pipewire-audio-client-libraries

...

And there's more:

Other packages are available; here's how to see them:

aptitude -t bullseye-backports search '~U~Abullseye-backports' 

You may need to install aptitude first!

And here's the Debian backport documentation.

Cautionary Notes:

Before adding any of the Debian backports to your system, there are some things you should know:

A. Know first that you should have a good backup before installing any Debian backport.

B. Despite statements on Debian's website, not all Debian backports are compatible with all Raspberry Pi models.

The "bottom line" is this:

bullseye-backports should not be used unless you're on a Raspberry Pi 3 or later model hardware - or a Zero 2W.

C. You should know how to "revert" packages installed from backports. For example, if you just used Debian's bullseye-backports to install a later version of pipewire on your Raspbian system as follows:

sudo apt install -t bullseye-backports pipewire pipewire-audio-client-libraries

You can "revert" that installation from bullseye-backports back to bullseye as follows:

sudo apt install pipewire/bullseye pipewire-audio-client-libraries/bullseye

Epilogue:

As it turns out, parts of this answer were already provided by John Goerzen in his blog post "Installing Debian Backports on Raspberry Pi". This is a very interesting read. Note in particular his recommendations to use the form apt-get -t bullseye-backports install. And I share his annoyance with the RaspberryPi organization. REF my latest row re their documentation. Perhaps fortunately (remains to be seen) the "worker bees" at RPiOrg don't share the same attitude as the owner's wife!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.