5

I'm running default raspbian with the desktop environment. If I start omxplayer without allocating a console, I have no access to the control keys and can't get it to exit. Am I doing something wrong?

Is there a better video player that I can install in a conventional desktop environment? (i.e. not boot into a custom XBMC or similar UI)

Edit: to clarify, I tried starting omxplayer by selecting a video file on the desktop and using Open With... omxplayer %f.

  • 1
    Doesn't it exit when you press q? – Jivings Aug 7 '12 at 6:15
  • 1
    How are you starting it? – Alex Chamberlain Aug 7 '12 at 6:31
  • Starting it from the GUI. – Kevin Peterson Aug 7 '12 at 15:01
5

To open properties of the file (mp4, flv ...). In users comand:

lxterminal -e omxplayer %F

The console and your file will be started. All comands (hot keys) will work.

3

You can quit your video by pressing the letter 'q'. If you want to start with a gui you can check this website

http://jeffhoogland.blogspot.ca/2012/08/howto-launch-omxplayer-via-gui.html

2

If you still have access to a terminal (e.g. if you are logged into your Pi remotely) you can do:

kill $(pgrep omxplayer)

(my raspbian doesn't have killall installed).

You should start the player from a terminal, and if you want a full screen black bacground, start the player with

xterm -fullscreen -fg black -bg black -e omxplayer -r %f

in the Desktop Open with... (install xterm with apt-get install -y xterm). That gives non-distracting black borders.

As for a better player, I don't think there currently (March 2017) isn't any. VLC can be installed but has not hardward support. Compiling VLC from scratch with --enable-rpi-omxil following these instructions, took an hour or so and did not get a working solution on my Pi3.

0

If you use the "Open with" option from the GUI you have to select "Execute in terminal emulator" option.

lxterminal -e omxplayer %F also works if you are on lxde,

Looks like the the the 'q' button and other shortcuts don't work if the terminal is not open. I had to power off the Pi a lot of times until I figured this out.

0

Used successfully in Jessie through to Stretch. Follow carefully as below.

Then to answer the question use q on the keyboard.

Start the File Manager and find (say) a sample .mp4 video file. Right click on that video file. Select Open With. Select Custom Command Line. Enter this in Command Line to Execute "omxplayer -o both". IMPORTANT without the quotes "" they mark start and end of the command only. Select Execute in Terminal Emulator. And also select Keep Terminal Window Open (needed if you want some control over the player). Then in Application name enter something like "Omxplayer (video)". IMPORTANT again without the quotes "" - or something similar - needed for the association to be remembered and for the above to appear as a right click option. Finally select Set Selected Application as Default. Then click on OK.

Here on double click on any .mp4 file and omxplayer will start via a persistent Terminal Window. You will need to use keyboard keys for control so search for the keyboard commands for omxplayer. However, you can start with (q)uit, (p)ause (space) and the arrow keys.

Repeat the above on sample .mkv, .avi and other video files for them to open similarly in omxplayer.

Addition: use these keys for control: q quit | z show info | p, space pause, continue | arrow keys navigation | i,o navigation: previous, next chapter | j,k previous, next audio stream | n,m previous, next subtitle stream | w,x show, hide subtitles | -,+/= decrease, increase volume.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.