0

My PC is running Windows 11 x64. I am trying to connect my Pi zero to my PC as a USB Ethernet gadget and SSH into it. My PC is also connected to the internet through a proper LAN connection. When I connect the Pi zero to Putty running on my PC, it says 'hostname doesn't exist'. However, I am able to ping into the Pi zero with 'ping raspberrypi.local'. I find that the IP address assigned to Pi is similar to the IP of my PC, assigned by the LAN i.e. both my LAN as well as Pi zero have the IP addresses in the series 10.1.5.x. When I disable my PC's LAN connection, I find that the IP address assigned to Pi zero is of the series 169.254.x.x, which is the usual series for Pi.

Kindly help me in resolving the above issue. I would like my PC to be connected to the LAN as well as Pi zero simultaneously.

3
  • Your PC is NOT assigning anything (probably because it is incorrectly setup). This is NOT a Pi issue. 169. is a Link Local address. If you are attempting to use ICS the Pi could access internet but not the PC. If you use Link Local the PC can access the Pi but the Pi can't access anything else.
    – Milliways
    Commented Apr 29 at 10:46
  • See raspberrypi.stackexchange.com/a/98738/8697
    – Milliways
    Commented Apr 29 at 23:59
  • @Milliways Thanks for your response. ICS is not enabled and I don't intend to connect my Pi to internet through my PC. I just want to SSH into the Pi from my PC.
    – Raghavan K
    Commented Apr 30 at 5:54

2 Answers 2

0

If the Pi is connected via Ethernet you should be able to connect using Zero Conf over Link Local; use ssh [email protected].

If your PC has a DHCP server and is allocating addresses this should work but configuring a PC is not a question for this site. If it only allocates an address if connected to your router the PC is probably sending traffic to the router.

I have never tried using dwc2 but provided your PC can see the Pi it should work.

Not all network services are available on Link Local.

2
  • As I stated in my question, my PC is connected to the internet through an ethernet cable, say Network 2. When my Pi zero is connected to the PC while Network 2 is enabled, pi zero is getting assigned a different IP and the packets are lost. However, when the Network 2 is disabled, pi zero gets assigned an IP in the 169.254.x.x series and gets detected and SSH also works fine.
    – Raghavan K
    Commented May 1 at 5:16
  • @RaghavanK you did make statements to that effect but provided no details of status or how it is configured. In any event this is a Windows issue. The Pi appears to be operating normally (although again lacking detail).
    – Milliways
    Commented May 1 at 6:09
0

Try to connect Putty to the IP address (10.1.5.x) of the Raspberry Pi. You might configure Putty IP address to match the Raspberry Pi hostname. That is what I have done using Bitvise (kind of like Putty).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.