0

When booting my old Raspberry Pi 2 Model B, it freezes with a rainbow screen. At the same time, the ACT LED flickers 2 times, then blinks 1 time, then turns off.

I already tried different chargers, including exactly the one that I used years ago when it worked. I'm also using the exact SD card that I used back then. fsck finds no issues with the file system. I used Raspberry Pi Imager v1.8.5 to write Ubuntu 22.04 image onto the SD card. Unfortunately, I currently only have this SD card.

I haven't used this Raspberry Pi for many years now, it was stored in a small paper box in a drawer.

What is the most likely culprit here? Is there a likelihood that the board itself is broken?

1 Answer 1

3

Ubuntu probably won't run on an old Pi with limited memory.

Install Raspberry Pi OS Legacy which is the recommended OS .

1
  • Thank you. I just tried Raspberry Pi OS (32-bit) Release 5.2 March 2024 and it appears to boot now (although it didn't finished to boot yet). Commented May 6 at 1:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.