I am using my RPi for some time now as a family server mostly for file sharing. Up till now I never had to access the internet via it (to the best of my knowledge). But now I would need it to access the internet in order to download an OMV plugin.

The only modification I did (to the best of my knowledge) to the RPi in terms of its network settings, was to assign a static IP address to the RPi within my home network. Otherwise I did not touch it. Now if I ping the router it works without issue. Yet if I ping or Google.Com I get no response (network is unreachable).

What else could I do to diagnose and fix the issue? Looking at the guides on the internet it seems the internet connection should be a "plug and play", without requiring any further modifications. It also doesn't seem one would need to enter an SSID and WPA2 anywhere, which I find strange as all my other devices that are connected to the internet via WiFi or Ethernet need to do so.

I am using debian bullseye legacy 64-bit lite as the operating system on a Pi 4 Model B (8GB).

Here are the static IP settings that were setup directly via OMV (Network --> Interfaces):

eth0 setup for IPv4 was changed from the method from DHCP and no pre-fixed settings to:

IPv4 method: "Static"

IPv4 Address: "to the desired IP" (same as routers except for the last digit)

IPv4 Netmask: ""

Gateway to "x.x.x.1" (thus the router)

1 Answer 1


Your problem "was to assign a static IP address to the RPi within my home network". If you let your router assign an address it would have set up correctly.

I recommend that you remove whatever you did and if you want your Pi to have a known address reserve one in your router.

NOTE OMV normally uses systemd-networkd rather than the usual networking methods.

You need to explain (in your question) exactly what you actually did if you want help. Listing the output of ip a & ip r would assist.

  • So OMV offers you the ability to assign a static IP. By Going under Network --> Interfaces. And then I have changed the settings of eth0 for IPv4 method from DHCP and no pre-fixed settings to IPv4 method: "Static" IPv4 Address: "to the desired IP" IPv4 Netmask: "" and finally the Gateway to "x.x.x.1" (thus the router). You are saying I should reset these settings and try again right?
    – Noir
    Commented May 6 at 7:38
  • You were correct, as soon as I implemented the DHCP protocol I could ping google and Still two question left on my mind: 1. Why can the RPi access the internet via my router without ever providing a password? 2. Is there a way to have a static IP and access via the internet? Do I need to configure my router for this?
    – Noir
    Commented May 6 at 9:43
  • DHCP provides all the necessary settings to clients which is why it works. If you provide these settings when configuring static (l am not that familiar with systemd-networkd so can't specify in detail) it would work. The best approach is still to reserve an address on the router so it does what it necessary so you don't need to have this complication.
    – Milliways
    Commented May 6 at 11:15
  • NOTE setting an arbitrary address is dangerous as it may conflict with existing or future allocation with unpredictable results.
    – Milliways
    Commented May 6 at 11:20
  • So you are saying I should have set the static address on the router side and not on the OMV side?
    – Noir
    Commented May 6 at 11:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.