I am using Rasperry Pi Model B. I installed Frodo (12.2) on it and everything works fine. I can ping the box, use browser interface etc..

I am facing issue with SSH.
I did following things:

  1. Kept ssh in cmdline (it was there in image and didn't remove it)
  2. Created files 'ssh_enable' but no luck. (so created some other files like 'enable_ssh' 'ssh_enabled')

I don't see any issue with network. I can ssh to other PC of network.

I also tried checking TCP port of SSH (22), but it says connection refused.

telnet 22
telnet: connect to address Connection refused
telnet: Unable to connect to remote host

How to fix this?


The easiest way for me (I use the RaspberryPi headless, i.e. without monitor/television connected, was to:

  1. turn the RaspberryPi off,
  2. take the SDcard and put it into my card reader at my PC.
  3. There I mounted the first partition on the SDcard and changed the file cmdline.txt in the root directory (aka / directory), adding the word ssh to the line that ended with quiet

There are many other interesting boot arguments (unrelated to ssh) described here.

More ideas in this OpenElec forum thread.

  • This should be the accepted answer!
    – KD.
    Apr 3 '16 at 13:55

Openelec Settings


Enable SSH

this worked perfectly for me, I then logged in using SSH from my HTC1 phone using root as the pi user didn't work

  • 1
    This only works if you have a monitor/screen/television connected.
    – erik
    Mar 5 '16 at 0:37

Can you explain a little bit here and I can try to help you. Are you trying to SSH into Raspberry Pi running openELEc from a Windows?

On OpenELEC SSH can be enabled during installation. To connect to it, you can use PuTTY from Windows. Again you may already know this but your question was not very clear to me.

  • No. Tried from MAC and Ubuntu.
    – navaltiger
    Mar 31 '14 at 18:22
  • This »answer« should be a comment to the question. This is not an awful forum — fortunately!
    – erik
    Apr 4 '16 at 17:48

Are you using current stable version 3.2.4 from http://openelec.tv/get-openelec/download/viewcategory/10-raspberry-pi-builds ?

According to OpenELEC website,

SSH is now disabled by default. This is due to security reasons. We disabled it by default as ssh normally would not be needed. With OpenELEC 3.1.x and higher, this has been implemented in the OE-settings add-on.

Try enabling ssh from OpenELEC configs from XBMC>Add-ons>OpenELEC_config (alternative locations: XBMC>Programs>OpenELEC or XBMC>Settings>OPENELEC).

Also, make sure ssh service is ON under XBMC>System>Services, if that option is available for OpenELEC.

New versions of OpenELEC may not recognise ssh_enable file.


Try to add ssh as the kernel parameter. There should be a txt file in the boot partition of the card for that.

  • Hello and welcome to RPi.SE you could further improve your answer by being more specific (e.g. provide the name of that file or how that parameter string looks like).
    – Ghanima
    Oct 9 '14 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.