the HDMI on my pi seems to be acting up, I've gotten it to boot 2/3 times after a few minutes, in the middle of configuring a controller in emulation station for example.

It's booting, my TV is recognising the HDMI input is coming from a Pi but I'm getting no signal.

I've tried different HDMI, Charging cables, Keyboards/mice. I've expanded the file system already during my initial boot (8GB class 10 SD card).

Beyond a reinstall of the OS i'm out of ideas.

Any help?

  • 1
    Is the HDMI cable plugged in during boot? Also, check out the RPiconfig eLinux page. There are a couple settings you can mess with in the config.txt file in the boot partition that control the way video is displayed. Mar 27, 2014 at 20:03
  • 1
    Yes, I agree with RPi Awesomeness. Another thing you can do is try using RCA and see if that works. Apr 12, 2014 at 22:56

3 Answers 3


Try adding hdmi_force_hotplug=1 and hdmi_safe=1 to the config.txt file of the SD card. This should put the Pi into a generic video configuration that works almost all of the time.

  • I've already got the : # uncomment if you get no picture on HDMI for a default "safe" mode #hdmi_safe=1 And the: # uncomment if hdmi display is not detected and composite is being output #hdmi_force_hotplug=1
    – Diehard
    Mar 27, 2014 at 16:44
  • If it's still not working with those configuration settings changes, then odds are it's either a hardware issue with the Pi or a firmware issue. In the latter case a different version of Raspbian may work better.
    – Fred
    Mar 27, 2014 at 16:50

I would suggest, firstly, looking at the the SD card compatibility list SD Card compatibility list, especially as you mention that you've got it to boot only 2 or 3 times. I've had problems with a kingston 8gb class 10 card where mine would only boot to raspbian every so often. a new samsung card fixed that for me.

Another issue could be power? I'm not sure exactly on your configuration, you don't mention whether you have a powered usb hub for your usb devices?, it could be that the Pi is not getting enough power on it's own to fire up all connected peripherals and the HDMI. I would try disconnecting all devices and seeing if it works then (if you haven't already)

I use retropie without any issues, but all my external devices (controller, keyboard, mouse, wifi) are powered from a externally powered usb hub.


Something that has happened to me (Although I am a bit stupid) is there is a 'read only' switch on the SD card, which sometimes I accidentally push up, and that doesn't let it load ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.