0

I have a raspberry pi 5, and it won't boot from any image on any usb drive, but it works fine on microSD. I already tried setting nvme/usb to priority (to no avail) and tried flashing a drive with the boot tool specifically designed to switch it to boot from usb. The green LED status flashes green twice (which isn't found anywhere in the manual) and then goes solid green. After around a minute it will repeat the pattern. Every time the pattern repeats, the status lights on the usb drives also indicate that they are being used. I can't see any outputs since the only display I have requires ssh in order to download the drivers for it.
enter image description here

This is the weird LED pattern that I have not been able to find any documentation for.

I tried adding

sudo apt-get update && sudo apt-get install rpi-update 

sudo BRANCH=next rpi-update

echo program_usb_boot_mode=1 | sudo tee -a /boot/config.txt

to config.txt but it didn't change anything.

When using raspi-config, this is the message it gave me when I switched the boot order to prioritize usb devices

enter image description here

EDIT: adding on to the things I've tried, I tried using the eeprom manager found here, but it just reboots, does the 2 flashes thing, and then boots back up from the sd card.

FINAL EDIT: updated bootloader using eeprom manager to a slightly older one, changed boot order, and it worked.

enter image description here

18
  • what is the USB device you are trying to boot from? can you explain what you meant by flashing a drive with the boot tool ... is that on a microSD or some USB device (it's clear your Pi can't boot from USB, so no matter what you put on the USB it won't boot from it) - also, those lines in config.txt will not help, since config.txt is NOT a scripting file, it's a configuration text file - and also since your Pi doesn't boot from USB ... well, you can see the issue, right Commented May 16 at 0:03
  • I'm using the raspberry pi imager, I tried both lite and full 64 bit raspbian. Commented May 16 at 1:23
  • what is the USB device you are trying to boot from? Commented May 16 at 1:54
  • @JaromandaX it is a transcend MLC 16gb usb drive. I also tried a Sandisk Cruzer 8gb drive, and for overkill, a WD 232gb external hard drive Commented May 16 at 1:56
  • 1
    @JaromandaX It will boot from USB by default if you don't have an SD card in (presuming there's a properly formatted USB drive). @Swerve: Wherever you saw that "solution", if it really said put that in config.txt, never read anything from there again.
    – goldilocks
    Commented May 16 at 15:00

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.