2

Is it possible to disable UART in Raspberry Pi??

I undid what I have done to enable UART in Raspberry Pi, but UART pins(8 and 10) can't be freed because when I tested with an LED, it glows on boot-up automatically.

Steps done:

  • Uncommenting this line in /etc/inittab

    #0:23:respawn:/sbin/getty -L ttyAMA0 115200 vt100

  • Adding console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 in /boot/cmdline.txt

    dwc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait

  • Do you have the respawn of getty for ttyAMA0 commented out when trying to access the UART directly? How are you planning to use the UART directly? Your question is confusing, you should list how you have your Pi configured and that you are unable to control the UART with this configuration. – HeatfanJohn Mar 28 '14 at 15:52
  • Once the system is up and running, and provided you've altered the cmdline.txt and the /etc/inittab files so that nothing is using /dev/ttyAMA0, there's nothing stopping you from using those GPIO pins normally. Have you actually tried to change the state after boot to turn off the LED? – Fred Mar 28 '14 at 23:03
1

/boot/cmdline.txt should be

dwc_otg.lpm_enable=0    root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait
  • Tried, but the LED still glows on boot up. But it won't glow with other pins – Ron4326 Mar 28 '14 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.