0

Unfortunately, I wasn't able to make this post with all the information I wanted to give. I was originally going to post it from the RPi 400 that I was having all these problems on, but apparently this website wasn't going to let me post it from there? Anyway, I keep trying to run tkinter on there, but it keeps failing, saying it can't find _tkinter among other things.

Since tkinter is supposed to be packaged with python3, I tried the following:

from tkinter import *

This gave me traceback messages including: If this fails, your Python may not be configured for Tk and ModuleNotFoundError: No module named '_tkinter'

After that, I tried python3 -m tkinter in terminal to see if that would do anything. I got the same result as above, though it did have a longer traceback. Since the traceback was insisting that tkinter wasn't present, I tried running sudo apt-get install python3-tk to add it, but it said I already had it on version 3.7.3-1 and that nothing needed to be done.

I found this weird, since I'd run python -V and it had told me that I was on Python 3.8.0. However, if I run python3 -V, I get Python 3.7.3.

I'm still figuring all this out, but I'm pretty sure I screwed something up bad. Any advice? The RPi doesn't have anything important saved on it, so I wouldn't be losing anything if I sent it back to factory settings if it comes to that, but I'd prefer not to if I can avoid it.

4
  • what is this question asking? ... but apparently this website wasn't going to let me post it from there?
    – jsotola
    Commented Jun 6 at 18:51
  • @jsotola mostly just commenting grumpily to myself. I had a lot more information to post here, but every time I clicked "review question" nothing happened. Something with the tags I think, but that's just a guess. I had to sign in on a different computer to post the question and ended up losing all the info I had collected to illustrate my problem; stuff from bash that might have helped narrow the problem down
    – Anonymaton
    Commented Jun 6 at 20:23
  • You are running an old unsupported OS. Do a fresh install of a current OS.
    – Milliways
    Commented Jun 7 at 2:00
  • @Milliways I'm trying that now, and yeah that seems to have been the case. I was running it on the os it came with out of the box (os preloaded onto sd that came with the kit). New OS seems to be working, though it might have mixed up the " and @ characters on my keyboard? As in, I do shift ' for @ and shift 2 for "
    – Anonymaton
    Commented Jun 7 at 2:06

1 Answer 1

0

Milliways was on the money! Used the RPi Reflasher and now everything is right as rain! It makes sense that the OS was outdated in 2024, but I was having these problems back in... end of 2021, January of 2022? Anyway, I was having these problems when the system was fresh out of the box. Either way, problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.