6

I'm using the raspberry pi with the latest ArchLinuxARM image.

I'm having issues with the linux kernel and it randomly panics with 'kernel paging request' errors.

I've found a solution to enable slub debugging in the linxu kernel here and here which tells me to edit /boot/cmdline.txt and add slub_debug=FP at the end of the command line.

I did that but the issue persists and I keep getting kernel panics. Now, other people having that issue report the slub debug option fixed their kernal panic behaviour. They are basicly using debian derivates on their pi.

Now I wonder if the /boot/cmdline.txt is the correct way to change the arch linux kernel command line in ArchLinux?

Any ideas what else I could try?

4
  • 1
    /boot/cmdline.txt should be the correct file. Check the settings have taken effect though by running cat /proc/cmdline.
    – Fred
    Mar 29, 2014 at 18:41
  • Do you overclock?
    – avra
    Mar 31, 2014 at 8:03
  • @avra No, I'm using default clocking. I didnt change the settings at all, why?
    – q9f
    Mar 31, 2014 at 9:33
  • @vertoe: Because with overclocking some problems look like yours. If you are sure that Pi never goes over default 700MHz then it's something else.
    – avra
    Mar 31, 2014 at 17:36

1 Answer 1

3

Yes, the /boot/cmdline.txt gets read correctly and can be verified by checking:

cat /proc/cmdline

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.