0

I want to install the last version of Minimodem on my Raspi.

If I do:

sudo apt-get install minimodem

I obtain the version 0.8.1, which is not the last one that the author has released. The last version incorporates some features that I need.

Here: ftp://ftp.us.debian.org/debian/pool/main/m/minimodem there is the compiled version 0.19 (which is the one I want to install) for armhf, but when I do:

 wget ftp://ftp.us.debian.org/debian/pool/main/m/minimodem/minimodem_0.19-1_armhf.deb

And then I try to install it:

 sudo dpkg -i minimodem_0.19-1_armhf.deb 

There is a depedency problem:

pi@raspberrypi ~ $ sudo dpkg -i minimodem_0.19-1_armhf.deb 
(Reading database ... 72372 files and directories currently installed.)
Preparing to replace minimodem 0.8.1-1 (using minimodem_0.19-1_armhf.deb) ...
Unpacking replacement minimodem ...
dpkg: dependency problems prevent configuration of minimodem:
 minimodem depends on libfftw3-single3; however:
  Package libfftw3-single3 is not installed.

dpkg: error processing minimodem (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:
 minimodem

The libfftw3-single3 seems to be not available, if I try to install it:

pi@raspberrypi ~ $ sudo apt-get install libfftw3-single3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libfftw3-single3 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libfftw3-single3' has no installation candidate

Is there some way to fix it and install the last version?

1 Answer 1

0

It seems that the best solution is gitting minimodem and compiling your own version. You will need to:

sudo apt-get install git
git clone https://github.com/kamalmostafa/minimodem.git
sudo apt-get install libpulse-dev
sudo apt-get install libsndfile1-dev
sudo apt-get install libfftw3-dev
sudo apt-get install libasound2-dev
cd minimodem
./configure
make
sudo make install

At the end, you will have:

pi@raspberrypi ~ $ minimodem -V
minimodem 0.19
Copyright (C) 2011-2013 Kamal Mostafa <[email protected]>
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Kamal Mostafa <[email protected]>.

... and

pi@raspberrypi ~ $ minimodem --benchmarks
minimodem 0.19 benchmarks
model name      : ARMv6-compatible processor rev 7 (v6l)
  generate-tones-lut1024-S16-mono
    frames count:       480000
    audio playtime:     10.000000 sec
    elapsed runtime:     0.084909 sec
    performance:        5653110 samples/sec
  generate-tones-lut1024-FLOAT-mono
    frames count:       480000
    audio playtime:     10.000000 sec
    elapsed runtime:     0.087484 sec
    performance:        5486717 samples/sec
  generate-tones-nolut-S16-mono
    frames count:       480000
    audio playtime:     10.000000 sec
    elapsed runtime:     1.642639 sec
    performance:        292212 samples/sec
  generate-tones-nolut-FLOAT-mono
    frames count:       480000
    audio playtime:     10.000000 sec
    elapsed runtime:     1.595292 sec
    performance:        300885 samples/sec

I've made some TX and RX tests. Everything is working fine.

You may do this quick and dirty test:

wget http://www.nonstopsystems.com/radio/snds-radio/radio-audio-rtty-170-45.wav
minimodem --read -a rtty --file radio-audio-rtty-170-45.wav

... and you will get:

### CARRIER 45.45 @ 1100.0 Hz ###
??? THE QUICK BROWN FOX JUMPS OVER THE LAZY DOG 1234567890 ??? THE QUICK
BROWN FOX JUMPS OVER THE LAZY DOG 1234567890

================================================================================== For historical purposes only

================================================================================== Try this way:

wget http://ftp.us.debian.org/debian/pool/main/f/fftw3/libfftw3-single3_3.3.3-7_armhf.deb

Then:

sudo dpkg -i libfftw3-single3_3.3.3-7_armhf.deb

==================================================================================

13
  • I got the next error: pi@raspberrypi ~ $ sudo dpkg -i libfftw3-single3_3.3.3-7_armhf.deb dpkg: regarding libfftw3-single3_3.3.3-7_armhf.deb containing libfftw3-single3:armhf: libfftw3-single3 breaks libfftw3-3 (<< 3.3.3-1) libfftw3-3:armhf (version 3.3.2-3.1) is present and installed. dpkg: error processing libfftw3-single3_3.3.3-7_armhf.deb (--install): installing libfftw3-single3:armhf would break libfftw3-3:armhf, and deconfiguration is not permitted (--auto-deconfigure might help) Errors were encountered while processing: libfftw3-single3_3.3.3-7_armhf.deb
    – Seitam
    Apr 4, 2014 at 13:09
  • Did you try sudo dpkg -i --auto-deconfigure libfftw3-single3_3.3.3-7_armhf.deb ? Apr 4, 2014 at 13:21
  • Seems to be dependency problems...: De-configuring libfftw3-3:armhf ... Replacing files in old package libfftw3-3:armhf ... Setting up libfftw3-single3:armhf (3.3.3-7) ... dpkg: dependency problems prevent configuration of libfftw3-3:armhf: libfftw3-single3:armhf (3.3.3-7) breaks libfftw3-3 (<< 3.3.3-1) and is installed. Version of libfftw3-3:armhf to be configured is 3.3.2-3.1. dpkg: error processing libfftw3-3:armhf (--install): dependency problems - leaving unconfigured Errors were encountered while processing: libfftw3-3:armhf
    – Seitam
    Apr 4, 2014 at 13:29
  • Ok, now redo sudo dpkg -i libfftw3-single3_3.3.3-7_armhf.deb and it will be installed Apr 4, 2014 at 13:33
  • 1
    After some benchmarks I realized that PulseAudio was consuming too much resources and the only way to demodulate a transmission live with SoftModem was by means of using ALSA without PulseAudio on the top. It works well but with an extrange behaviour, the data seems to be demodulated by bursts: it demodulates 5 seconds of transmission quickly, then stops during 4-5 seconds, and again in a burst demodulates the signal. That does not happen when the input is a sound file, only when the data is coming from the microphone.
    – Seitam
    Apr 14, 2014 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.