1

enter image description here

I have been trying to install this antenna on the pi but when I failed, I tried modifying the /etc/network/interfaces file via sudo nano /etc/network/interfaces to

iface wlan0 inet dhcp
wpa-ssid "MY ssid"
wpa-psk "MY password"

but there is no connection. I need to install this antenna to send files from the pi to a laptop wirelessly using the laptop's IP.

Any idea how to firstly configure this usb antenna and then how to send to a device?

I am using a Raspberry Pi model B running raspbian on it.

  • 1
    please edit your question and post the output of "lsusb" command so we can understand what device you're using. Maybe your distro didn't have your device's driver and it may not recognized yet. Without recognize it your config file will not work. – gurcanozturk Apr 5 '14 at 11:12
2

Try installing and using wicd:

sudo apt-get install wicd-curses

Now, you are ready to start:

sudo wicd-curses

You will get a list of wireless networks, found by RPi, and your wired network.

Using wicd with Raspberry Pi

Then, you can select your wifi network. Just highlight it with arrow keys and press right arrow key to edit its properties.

When you’re done, just press F10 to save it. It should connect!

| improve this answer | |
  • everytime I do so it terminated the ssh session without connecting. Is there a reason or something I am doing wrong? Ido choose my network and type the key then ok and finally C to connect. – Xys May 5 '14 at 3:22
0

I would recommend trying to setup wifi using the GUI. If you are using a monitor launch the GUI by typing startx into the command line. If you are using shh install tightvncserver and connect with a vnc client. The wifi config tool is on the desktop, it is pretty self explanatory.

| improve this answer | |
  • what if he/she didn't install X Server? Also he/she didn't mentioned what distribution he/she use. – gurcanozturk Apr 5 '14 at 11:09
  • I didnt install X server and I am usng raspbian – Xys Apr 5 '14 at 12:49
0

If I were you I would type the command

lsusb

And check the chipset of the WiFi dongle. It would save a lot of time in searching for it online.

I think in order to achieve your goal setting raspberry pi as an access point would do, I'm not really an expert but you can try doing that. I've set mine using the this link But notice that my wifi dongle chip is rtl8188cus. This may differ from yours.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.