2

I'm using the RetroPie image to install Emulationstation and Vice. Sound works fine in Emulationstation but I can't get sound to work in Vice. I tried all different sound drivers and settings in Vice and I tried all other suggestions I could find, like:

  • enable hdmi_drive=2 in config.txt
  • enable hdmi_force_edid_audio=1 in config.txt
  • enable hdmi_group=1 and hdmi_mode=4 to force CEA mode
  • start vice with all kinds of different settings (found out later that these are the exact same settings as provided in settings menu)

For some reason sound works in Vice for some Raspberry Pi users but does not for other users.

I'm using my Raspberry Pi with my Sony tv with HDMI. Sound works fine in openelec/xbmc. I tried Retropie 1.8.1 a while back and got the same results with current version 1.9.1.

All help is greatly appreciated. Thanks!

EDIT: Just found out that if I change sound output to headphone (by using the Retropie-Setup script) sound is working properly. I just doesn't work in Vice over HDMI with my HDTV (Sony). How can I get it to work on my HDTV?

  • Can you provide details on what you have tried (what other suggestions). Have you tried a pair of headphones or speakers rather than HDMI sound. Did you reboot between tryinng Emulationstation and Vice? – Steve Robillard Apr 13 '14 at 21:50
  • Thanks Steve. See my edit. I found this: elinux.org/R-Pi_Troubleshooting#Sound. I says: Secondly, it seems that some HD TVs mute audible sound output when there is only one channel of digital input. So, as the file Front_Center.wav is mono, it might not be heard. Might that be the reason sound is not working on my HDTV? Can this be fixed by some setting? – jzp74 Apr 14 '14 at 19:22
  • Have you looked at the config text options? Have you tried a file that has stereo or surround sound? – Steve Robillard Apr 15 '14 at 21:58
  • Thanks! I have just confirmed that stereo sounds play correctly over hdmi on my tv but mono sounds are not heard over hdmi on my tv. Vice probably produces mono sound and that is why I cannot hear it. I have tested the config options that seemed appropriated (hdmi_drive and hdmi_force_edid_audio) but without result. Do you have other suggestions? – jzp74 Apr 16 '14 at 19:02
1

Thanks for your help Steve.

Since mono sound is not supported over HDMI on my tv and Vice 2.3 (the one provided by Retropie) outputs mono sound only I browsed for options in Vice. Luckely Vice 2.4 supports an option to output all sound in Stereo. Found this post on a working 2.4 version of Vice: http://www.raspberrypi.org/forums/viewtopic.php?p=505178#p505178

Problem solved

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.