1

After trying to set up a static IP address by changing the etc/network/interfaces file and having it break connectivity following that, I decided to just set it back to default. I followed this post here and changed it to:

auto lo
iface lo inet loopback

I reboot and wifi still doesn't work. The error in WiFi Config is:

Could not get status from wpa_supplicant

And the /etc/network/interfaces file has changed itself back to:

auto lo
iface lo inet loopback
iface eth0 inet dhcp

auto wlan0
iface wlan0 inet static
  address 192.168.1.1
  netmask 255.255.255.0
  wireless-channel 1
  wireless-essid Jasper
  wireless-mode ad-hoc

Any ideas how I could get it working again? I'm new to Raspbery Pi.

  • Do you have a model b with ethernet? – AwesomeUser Apr 13 '14 at 22:18
2

I don't claim to understand all of parameters (although man interfaces will explain) but my still default /etc/network/interfaces (no wlan) is:-

This applies to Raspbian Wheezy prior to 2015-05-05 for later (and Jessie) See How do I set up networking/WiFi/Static IP

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp

It looks to me as if you still have static IP set, so you could try to change this to dhcp

1

Are you using the Jasper image from the Jasper Voice control project? If not ignore the following. If you are using Jasper:

The jasper authors added some smart system to make the Wifi setup easier. They create an Ad-hoc Network on Startup (Meaning your Rpi acts as a Hotspot and you can connect to it with your Notebook/Cell Phone). Then after connecting to the Ad-hoc Network, you can set-up the Wifi connection you really want to use. This is documented rather shortly here http://jasperproject.github.io/documentation/usage/.

I am guessing that since you tried the configuration manually, at each boot your raspi is reconfigured for the ad-hoc network.

If you really want to use Jasper, then you should either configure the Wifi as described in the Jasper Documentation, or find the code that reconfigures your connection and disable it (my guess would be something in /etc/init.d).

If you are using the Jasper image rather 'by accident', just get a regular raspbian image. If you don't there might be more surprises of this kind waiting for you in the Jasper image.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.