6

I am new to RP & have been searching for 24 hours for this.

I have a 'ThePiHut' USB wifi dongle. It seemed to install its own drivers when I plugged it in and I used the wpa_gui to successfully connect to a wireless network.

I now need to use an OpenVPN. My provider uses 'Network Manager'.

I have installed this and the gnome gui:

sudo apt-get install network-manager
sudo apt-get install network-manager-openvpn 
sudo apt-get install network-manager-openvpn-gnome

The gnome gui works, and I get a tray icon, and can click Add for VPN and Wireless. However - the windows that come up have every textbox greyed out.

Wifi/internet is still working. I have tried rebooting many times.

I'm sure I'm missing some crucial step or binding or something.

Primarily I'd like to get VPN working through a GUI. Perhaps I also need to get wireless working through the 'Network Manager' GUI too (both would be nice for easy of configuration'.

How can I do this? Is 'Network Manager' the best tool? Thanks.

3

I'm also fairly new to using the RP. I ran into the same problem using a wired network connection. I edited my /etc/network/interfaces file and removed the line "iface eth0 inet dhcp" and rebooted, this gave Network Manager control of the network interface.

A thorough description of Network Manager can be found here https://wiki.debian.org/NetworkManager

0

If using XFCE you can create a Desktop Launcher which has the command

sudo nm-connection-editor

You can choose to move this new Desktop Launcher to any Panel by right clicking on the Launcher and selecting 'Create Launcher on A Panel'. If you remove the Desktop Launcher the Panel Item you've just created will remain there.

I would assume that if one is not using XFCE that a similar solution can be used on the RPi's default desktop.

-1

I've read that Network Manager won't work if you're not root. Before starting LXDE, type sudo su-. That will give you root privileges. Then type startx. Then try to run Network Manager again, and the options should no longer be greyed out.

-1

For once Network Manager has to be enabled or started via SystemD on Debian8 and many other Distributions from terminal (as root):

systemctl enable NetworkManager

Second in the config file /etc/network/interfaces you have to comment all entries after the "loopback interface" lo with a hash #

For example auto wlan0 should be changed to this: #auto wlan0 Then restart NetworkManager or reboot if this does not help. To rebstart the service type thins in terminal or console (as root):

systemctl restart NetworkManager

  • 3
    Hardly an answer to the original question which was about Wheezy – Milliways Jul 10 '16 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.