3

I have a Pi running a super-stock Raspian installed with NOOBS (If I remember correctly). Yesterday, it was working fine. I stopped using it for a bit to debug some other parts of the project this Pi is going in, and when I came back to it, it was off, and would not reboot despite all the jiggling with the power cable, letting it sit, etc. This morning, I tried a different cable after leaving it unplgged for more than 12 hrs, but still no booting, not even a flicker from the lights, although I did notice the main chip gets pretty hot pretty fast. Not hot enough to burn, but I didn't leave it plugged in to see how hot it would get. The power adapter I'm using has worked with a few different Pi's for around a year now. What could have caused this, and is my Pi shot?

Here's everything I've tried:

  • New cable
  • Letting it sit overnight
  • Unplugging everything and trying to boot
  • Computer USB port for power
  • Checked SD card for corruption
  • Checked voltage on 5v pins, it read 5.04v.
  • Pulling the Pi off of its mount, just in case the screws were causing an issue somehow

EDIT: Here's what was plugged in:

  • A 2A tablet charger with its original USB cable
  • A USB keyboard, rated for 100 mA according to the label
  • A monitor using a HDMI-DVI converter cable
  • Two Arduinos via i2c, including ground wires
  • 8GB SD card

Another edit: I noticed that the round thing by the USB plug (capacitor?) is a little wobbly if you bump it. Could it be broken? Thanks for the help!

EDIT 3: I tried something that I probably shoulden't have, and that nobody reading this later SHOULD EVER TRY, I put 5v from a super-regulated supply across the 5v rail, and the Pi didn't boot. This leads me to the conclusion that it is fried, because if it was just other parts of the power system, this would have bypassed that.

EDIT 4: Consulting the schematics for the Pi found here: http://www.raspberrypi.org/wp-content/uploads/2012/10/Raspberry-Pi-R2.0-Schematics-Issue2.2_027.pdf I've found something else interesting. The red power LED (top middle, page 4) is attached to the 3.3v rail. Back on page 1, looking at the USB port to power rail, there isn't really anything that could break and cause this to happen, except the fuse, which I tested and has 0.0 ohms of resistance. The next thing I tested was resistance between TP1 and TP2, which I found to have infinite resistance, so no power system shorts. Moving on down the line, the next component that the LED's power goes through is RG2, the 3.3v regulator. Given the earlier measurement of 1.2v on the 3.3v rail, it is safe to assume that this regulator has gone bad for some reason. To further the point, the 2.5v and 1.8v regulators feed off of this regulator's output, so if RG2 goes bad, the processor won't work at all, as that's all the rails are used for.

  • Did you check the required power for the Raspberry Pi before plugging in the 2A Charger? You would have noticed that it must be 1A... My opinion? It fried. Sorry bud. – GonacFaria Apr 15 '14 at 14:59
  • 2
    With amperage, can't the device draw whatever it wants as long as its current draw is below the current limit of the power supply? If the Pi wants to draw 1A, it should be able to safely from the 2A supply with no problems. This power supply has also been working with multiple Pi for a long time now. – user2461671 Apr 15 '14 at 15:04
  • Whats the charger voltage? I still believe from what you said, that its burned. I hope not, of course. – GonacFaria Apr 15 '14 at 15:20
  • The charger voltage is 5v, it's just a standard usb charger. – user2461671 Apr 15 '14 at 15:35
  • Try reflashing the SD card. Number 1 problem with Pis is corrupted SD cards. I'm not sure how you checked the SD card for corruption. – Gerben Apr 15 '14 at 17:17
2

Why did you get a 2A charger bud? Your Pi would work great with only output of 5V and 0.7A. However in some projects when you need some more current, you can get a different power supply with 1A-1.5A. But if you're sure that you will be connecting more devices, which would require that much current, you would be good to go.

As you mentioned, the capacitor feels wobbly, I wonder that's the major reason why your Pi is not even booting (not even a single light lits up there).

Try with a charger that would be just sufficient (5V and 0.7A) and then measure the voltage between GPIO pins (Pin 1 and ground, voltage should be 3.3V and then Pin 2 and ground,voltage should be 5V). Don't connect too much devices when you power your Pi with this charger, just attach your Keyboard, Mouse, Screen and ethernet (if required) and test if it boots up.

If that doesn't work, that means your Pi is either fried or the capacitor is detached (or something) and causing the Pi not to get power.

  • I got a 2A charger because it's what I had lying around from my old Nexus 7. I only have my 2A charger with my right now, but I'll try some other ones tonight. – user2461671 Apr 15 '14 at 15:34
  • Great and test the voltage across the GPIO pins too... – Sanyam Khurana Apr 15 '14 at 15:35
  • I just tested the voltage across the GPIO, and they are 4.45v for the 5v pin, and 1.2v for the 3.3v pin – user2461671 Apr 15 '14 at 15:53
  • 1
    -1 The pi would draw what it needs. Using a 2A charger would not do anything. Using a 0.7A may only worsen the situation or cause confusion. – Gene Nov 20 '15 at 9:41
  • 1
    -1 Agree with @PandaLion98 - using a 2A is actually a good thing - it will have plenty of reserve capability and be less stressed by only having to provide a smaller quantity of current. – SlySven Dec 11 '15 at 14:17
2

Those "Two Arduinos via i2c" sound suspicious to me. The Pi's IIC lines have the pull-ups needed TO 3.3 Volts. The 3.3 Volt supply is VERY limited (50mA TOTAL IIRC) - so two things come to mind:

  • The Arduinos may also have IIC pull-ups but they are to the 5Volts that I think those devices use (if they are 3.3V devices then this ISN'T an issue) so they could have done BAD THINGS to the Pi or its 3.3V supply regulator.
  • If the Arduinos ARE 3.3V devices - did you power them from the Pi's 3.3V supply - that is BAD as mentioned above but it may be that the damage is not permanent in that disconnecting them will remove the overload from the Pi's 3.3V PSU regulator.

In either case I'd check the 3.3V rail again with those Arduinos completely out of the circuit. You may get around the first case with a 5V to 3.3V BI-DIRECTIONAL interface - I got a two channel one recently on a well know On-line Auction site (hopefully the link should not rot too quickly) which specifically noted that it was suitable for use on IIC.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.