2

I used to mount a Time Capsule share and everything was working great. Recently, probably after a system update, sudo mount -a give the following error:

$ sudo mount -a
mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

How can I fix the problem?

  • Can you paste the CIFS line of your /etc/fstab file please? Also can you check what version of cifs-utils is installed now by running dpkg -s cifs-utils | grep Version? – Fred Apr 18 '14 at 14:22
  • @Fred Version: 2:5.5-1 – ohho Apr 22 '14 at 7:12
2

The issue seems to be caused by a change in the default security mode of the Samba client installed on the RaspberryPi. Apple Time Capsule appears to only support the NTLM password hashing method and, apparently, this is no longer what the client provides (interestingly enough, the mount.cifs man page still states that NTLM is the default option though).

In order to force the client to set the security mode to what's required by Time Capsule, you need to explicitly set a relevant flag. Your /etc/fstab entry might therefore look like the following:

//192.168.1.1/Time-Capsule /mnt/TimeCapsule cifs credentials=[your_TimeCapsule_credentials_path],file_mode=0777,dir_mode=0777,rw,sec=ntlm   0   0

The most important bit is the sec=ntlm option and this is what should do the trick. However, please bear in mind that for security reasons NTLM is no longer recommended by Microsoft who originally designed it.

And just to confirm I have had exactly the same problem with my Time Capsule since December 2013 when I ran an APT update that included samba, samba-common and samba-common-bin package changes. All of them were what seemed like very minor updates though: from version 3.6.6-6+deb7u1 to 3.6.6-6+deb7u2. Fred has asked about the cifs-utils version and in my case it is currently 2:5.5-1. I'm not sure if this is relevant but this particular package did not get updated in that round of Samba changes.

  • sec=ntlm fixes the problem. – ohho Apr 22 '14 at 7:10

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.