5

I'm trying to use npm on my Raspberry Pi under Debian testing (Jessie). When I perform a command like:

 npm install -dnpm express

I get the error message:

Illegal instruction

This seems to be an error in the package. I tried to install the current version from http://nodejs.org/ manually, but I get the same message. What does that mean and what can I do?

  • Shouldn't the command be npm install -dnpm express? or just npm install express? or most likely sudo npm install -g express – Steve Robillard Apr 19 '14 at 20:32
  • @SteveRobillard Absolutely, I corrected that, this error is the same. – user5950 Apr 20 '14 at 17:09
  • 1
    Ths seems to be a known bug called the illegal exception bomb. This site claims to habe a solution schrankmonster.de/2014/03/22/… but I have not tried it myself. – Steve Robillard Apr 20 '14 at 17:38
  • It seemed to work at first, but now I have the error again. – user5950 Apr 21 '14 at 1:42
2

These two commands will install a recent ARM architecture supporting version of node and npm. Make sure to start a new session or use the bash command to use the new node and npm path variables.

wget http://node-arm.herokuapp.com/node_latest_armhf.deb
sudo dpkg -i node_latest_armhf.deb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.