I have a CAD Audio U9 Microphone external microphone with a clear sound on my laptop. I plugged it inside Rpi and the sound is very bad. I have glitches and noise.

I tried to change the gain inside alsamixer. It seems to change anything.

The external usb audio seems to work properly : pi@raspberrypi:~$ arecord -l ** List of CAPTURE Hardware Devices ** card 1: Device [USB PnP Sound Device], device 0: USB Audio [USB Audio] Subdevices: 1/1 Subdevice #0: subdevice #0

I use ffmpeg -f oss -i /dev/dsp1 command. I tried also ffmpeg -f alsa -i hw:1,0. It crashed the Rpi...

Any idea to solve the problem ?


  • 1
    I think this is a firmware issue that has not yet been resolved.
    – Jivings
    Aug 11 '12 at 0:26
  • @Jivings "firmware" meaning what exactly? Something sound related in the GPU? Something to do with isochronous USB transfers? Something else in the USB drivers? Something in the connected USB audio device? Aug 11 '12 at 3:14
  • Most certainly it can be USB driver problem. There are some USB bugs that are being worked on right now so I would suggest to be up to date with firmware. Do you have newest firmware version? Aug 11 '12 at 5:27
  • Oh and it would be interesting to know how it crashes RPi. If you have newest firmware and still has a crash it would be good to report it. Aug 11 '12 at 5:28
  • I used Raspbian “wheezy”. How can I make a bug report ?
    – hotips
    Aug 11 '12 at 6:46

Like Jivings said, there are communication issues between the rPi and USB input devices. There should be a fix sometime into the future.

Could just add a mic socket onto them GPIO thingy with all the pins.

  • How can I use GPIO with a microphone ? Do you have a link ?
    – hotips
    Aug 11 '12 at 6:47
  • 1
    You cannot connect a microphone directly to the GPIO. You could develop an expansion board with a high quality ADC that communicates over SPI I suppose. Aug 11 '12 at 7:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.