It's my first time trying the Raspberry Pi and I already have hamachi installed. I want to install the GUI part of hamachi as well so I'm trying to install haguichi and i get this error:

sudo apt-get install haguichi
Reading Package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package haguichi

Ugh. Ok i'm following this step https://help.ubuntu.com/community/CompilingEasyHowTo and i'm on step 2 but i'm getting the error

autogen.sh: command not found

i tried the make command and got the error

make: *** No targets specified and no makefile found. Stop 

i navigated to where the file is and i found

Makefile.am, Makefile.in, Makefile.include, Haguichi.make 

are those not 'make' files?

i run ./configure and found Configure error dmcs not found

Update --

I followed Bex suggestion and entered the code:

deb http://ppa.launchpad.net/webupd8team/haguichi/ubuntu precise main
deb-src http://ppa.launchpad.net/webupd8team/haguichi/ubuntu precise main

then I did

apt-get install haguichi

i'm not sure if it got installed, the last line was

Setting up haguichi-appindicator (0.1 1-2~webupd8~prcise)....

Then nothing happened after that.


Please stop "ugh"-ing. That is just the way it feels when you're learning.

You are on the right track. The files you have found are prototype make files, and can't be used in their current form. To generate a make file, you run configure. Great.

Now, configure tells you that you have a broken dependency - dcms is not installed on your system. You will have to resolve that, and sadly, the given information in the question is not enough for me to help you do that. Please share more of the output of the configure script if you want more help.

Alternatively, assuming you run something wheezy-based, you could try following the guide on the haguichi home page download site:

For Debian 7 “Wheezy” add the following lines to the file /etc/apt/sources.list
deb http://ppa.launchpad.net/webupd8team/haguichi/ubuntu precise main
deb-src http://ppa.launchpad.net/webupd8team/haguichi/ubuntu precise main

When done, execute the following command as root:
apt-get update && apt-get install haguichi

This may save you from (or rob you of) the experience of building your own.

  • Hi, I updated my description following your suggestion. But I'm not sure if it got installed or not, I don't see it on the desktop. – CCK Apr 25 '14 at 14:54
  • Aha, I found it on the 'Internet'. I'll try to configure it first – CCK Apr 25 '14 at 14:56
  • It says Hamachi is not configured. You need to configure Hamachi before you can connect. But I already configured Hamachi before, i entered my email address, and i even got it connected to the vpn. – CCK Apr 25 '14 at 14:57
  • when I enter sudo hamachi i see the version number, pid, status (logged in), client id, address, nickname and lmi account – CCK Apr 25 '14 at 15:00
  • Please start a new question if there is something specific you want to know of need help with. – Bex Apr 25 '14 at 15:02

protected by Community Apr 25 '14 at 16:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.