I have a rpi running as a home backup server. It used to work fine, had an uptime of months, but ever since rebuilding it a few weeks ago with the latest raspbian, it has started dropping off the network, and when I go and look at it, it only has the red power light on. Sometimes (I have no idea what triggered it), it came back.

In trying to figure out the problem, I have set up a crontab that outputs "uptime" to a text file. Having this cron job on seems to wake the box up when it falls asleep, but it still falls asleep: since adding the cron job (12h ago) it stayed up for 5h, and then seems to have fallen over regularly, rebooting 6 times over the next c6h. But it's not after a regular time: the longest it has reached is 1:45, whereas another time it rebooted after just 20m.

I found this question that I originally thought was related:

How do I disable suspend mode?

But I don't think it is now, for two reasons: I am not connecting via wifi (and no wifi adaptors are attached), and I am not running X at all. I ran the xset commands in the last answer anyway, out of desperation, but it made no difference.( Other info:

  • I have a Seagate Central mounted via CIFS/SMB (but I would not recommend them!) - this is the only thing that has changed since the set up worked perfectly, but I find it hard to believe this is the problem. Maybe I'll unmount it and see if it helps.
  • I have a USB hard drive plugged in
  • It's plugged into my router via a homeplug

Anyone any idea what might be going on? Could it be a bad SD card? I think I've tried two. What can I run to see if it is that?

1 Answer 1


This is most probably due to lack of power. Check your power adapter - can it output 700 mA? Change to one that can output more. Also, get a powered USB hub, and plug you hard drive in via that.

Good luck!

  • Hmm, interesting. There have been no power changes since it all worked, but maybe the adaptor (which was bought specifically from RS as a RPi adaptor, so I would hope it outputs 700mA!) has developed a fault. I'll try another and see how that goes. But the USB hard drive is powered itself, so presumably that wouldn't drain significantly...? Commented Apr 27, 2014 at 19:30
  • 700 mA is the absolute minimum. Get one that can do a little bit more. I might be very small changes (in software or peripherals, for example), that can influence the peak power consumption, and if your charger can't cope, the pi will reboot.
    – Bex
    Commented Apr 28, 2014 at 6:24
  • My adaptor claims 1.3A, so should be fine. I've switched to another (1A) and left it overnight, and it's still up. I'll give it 48h before coming to any conclusions, but early indications certainly seem to be a faulty power adaptor. Thanks! Commented Apr 28, 2014 at 10:33
  • Cool. I'll keep my fingers crossed.
    – Bex
    Commented Apr 30, 2014 at 5:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.