FOUND THE PROBLEM: apparently my Raspberry is somehow broken because it does work on the raspberry from someone else...

I bought the raspberry and a strand of ws2801 led pixels and I try to make them light. The only thing they do is glow white (all of them), does anyone have this problem and know what to do??

The only thing I can think of is that the led's maybe are faulty or they are not ws2801 ( got them from china so you never know..) but then I don't know which they are supposed to be.

  • images of wiring + pixel: enter image description here enter image description here
  • Have you buzzed through the ribbon cable? They tend to reverse the ranks which you seem to have catered for. Are you sure it hasn't been twisted so pin 1 is now pin 26? Perhaps check the voltage between red and black is +5V. The Python contains a function slowspiwrite. If you called that function by mistake it will stop the hardware spi working properly (by changing the gpios to the wrong mode).
    – joan
    Apr 27, 2014 at 16:23
  • Not sure how you could check if they were actually WS2801. Magnifying glass maybe?
    – Fred
    Apr 27, 2014 at 17:47
  • The power connected to the LEDs also power the raspberry so they are connected correctly, otherwise the pi wouldn’t work :). I already tried it with a ton of tutorials when I still had the wheezy distribution but there was also only one that worked (from hackerspace I believe) and those also made the lights shine white. I will recheck my code for the slowspiwrite. Apr 27, 2014 at 18:17
  • Hmm the hardware spi did stop working properly since the raspberry does get power but does not start up anymore when connecting it to the led wires. But I do not call the slowspiwrite anywhere. Apr 28, 2014 at 8:24
  • Please answer you own question, instead of including the answer in you original question, and please mark it as accepted. Thanks
    – Piotr Kula
    Apr 29, 2014 at 11:35

2 Answers 2


Have you tried using the slowspiwrite instead to check if the LEDs function properly ?

After the lines:

SPIDO = 17

Add the following:

for byteout in range(1, 255, 10):
    slowspiwrite(SPICLK, SPIDO, byteout)

This will test the slowspiwrite and finish the code before reaching the real SPI part.

You will also need to change the wiring from pins 10 and 11 to pins 17 (yellow) and 18 (blue marine).

  • The LEDs work, apparently I have a faulty raspberry since it does work on the raspberry of someone else :(. Apr 29, 2014 at 9:20
  • I have a similar problem trying to control other device with SPI. Now that you say it I may have a faulty one as well. Where did you buy yours?
    – DWilches
    Apr 29, 2014 at 13:18
  • Hello, There is another possibility and is SPI is not correctly configured in your RPi. Could you post the output of this command: lsmod | grep spi
    – DWilches
    Apr 30, 2014 at 0:52
  • Also, could you tell me which kernel is installed in your RPi's and your friend's (uname -r)? I've found that kernel 3.10 has problems with SPI: raspberrypi.org/forums/viewtopic.php?f=44&t=57516
    – DWilches
    Apr 30, 2014 at 3:53
  • new pi: lsmod | grep spi = spidev 5600 0 spi_bcm2798 5385 0 and uname -r = 3.1.9adafruit+ the faulty one gives the same output. I ordered it at bol.com, the box it was in said element14 (UK) May 1, 2014 at 7:47

The Raspberry turns out to be faulty.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.