5

Currently the raspbian os we installed is not booting up with a login screen. How can I boot it up to a login screen so that we can enter a username & password and so that it doesn't go directly to desktop?

4

you can open a terminal and type

sudo raspi-config

There you can go to

3 Enable Boot to Desktop/Scratch

and select Console.

After a reboot, you should be good to go.

0
1

Open the terminal and type: sudo raspi-config

Then select Boot > Desktop / CLI > Desktop instead of Desktop autologin.

Now just reboot.

0
0

If you select boot to desktop, it will not give you a login screen. The only time you have have to put in a password is if you select boot to terminal.

I don't believe there is a way for you to have a login screen.

1
  • This is incorrect; you may have to disable autologin, (which is a separate issue from whether you boot to console or desktop, although I think it requires desktop mode), but there is a GUI login screen. – goldilocks Mar 23 '20 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.