12

I have installed Chromium on my Raspberry Pi (running Raspian) with sudo apt-get install chromium-browser and I followed the instructions from this site to attempt to get flash player running: http://linuxologist.com/01general/howto-chromium-browser-on-linux-with-flash/

ie I just downloaded libflashplayer.so, placed it in /usr/lib/ then make a symlink to it in /usr/lib/chromium/plugins/. then i open Chromium like so:

chromium --enable-plugins --enable-greasemonkey --enable-user-scripts --enable-extensions

from the command line. However, flash player is still not recognised. The version of flash player I downloaded was from softpedia in tar, which i had to untar.

Has anyone managed to get this working? If so, then what extra steps were required?

Update

Alex requested I run file, so here it is:

$ file /usr/lib/libflashplayer.so
libflashplayer.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped
  • You are aware that Linux can run on multiple platforms and you need one fitting your hardware. In this case an ARM cpu. – Thorbjørn Ravn Andersen Aug 12 '12 at 8:03
  • Even if you get it running, flash will not run well on the Pi. I don't think you should put any more effort into getting it to work. – Jivings Aug 12 '12 at 10:49
  • @ThorbjørnRavnAndersen yeah i've been using linux for a while now so i am familiar with it. i wasn't sure if the libflashplayer.so file would have support for arm - i guess i was a bit hopeful there... – mulllhausen Aug 12 '12 at 15:05
  • @AlexChamberlain ah right! haha i'll update the Q – mulllhausen Aug 12 '12 at 15:10
  • @Jivings the pi has hardware accelleration for h264. It could be made to work relatively well for video playing. – Thorbjørn Ravn Andersen Aug 12 '12 at 16:01
16

ARM vs x86

Intel processors used by desktops are 32/64-bit architectures, generally known as x86 and x86_64.

ARM processors, which is used by the Raspberry Pi, also use a 32-bit architecture, but it is incompatible with x86. Therefore, x86 libraries will not run on the Raspberry Pi.

How do I know you have an x86 library?

I asked you to run

file /usr/lib/libflashplayer.so

which output

libflashplayer.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, stripped

Intel 80386 tells us it was compiled for x86.

Do Adobe release an ARM version of Flash?

Yes and no. There are versions available for a lot of Mobile platforms, but I believe it is being deprecated (citation needed) and I haven't seen it available for ARM Linux. (citation needed)

4

I think Adobe did not release any flash plugin of ARM Linux.

http://get.adobe.com/flashplayer/otherversions/

I don't know where do you get the "libflashplayer.so", but i guess it is X86 or X64 version.

  • Hi lxp121 Welcome to Raspberry Pi Stack Exchange. Usually the best answers are supported by facts and citations. Currently this is not a complete answer, can you please improve it? – Jivings Aug 12 '12 at 10:32
  • @jivings this is a widely known fact. – Chris Stratton Aug 12 '12 at 15:31
  • @ChrisStratton: The original answer did not include the link or 3rd line. – Jivings Aug 12 '12 at 19:27
  • It did not need one, as the fact is widely known. – Chris Stratton Aug 12 '12 at 20:18
4

Gnash

Gnash is a free SWF movie player. It is available as a stand-alone application or as a plugin for several popular web browsers. It supports playing media from a disk or streaming over a network connection. Some popular video sharing sites like YouTube are supported on a wide variety of devices from embedded ones to modern desktops.

Installation

Gnash should be in the distributions' repositories.

Debian

$ sudo apt-get install gnash

Arch

$ sudo pacman -Sy gnash

Configuration

It should Just Work, but I haven't tried it yet. Will do soon.

References

  1. Gnash User Manual
  • I don't think you meant the -y flag for pacman. That synchronizes the package list, something that is unnecessary when installing software. – user46 Aug 13 '12 at 20:14
  • @BryanDunsmore Or I did... – Alex Chamberlain Aug 13 '12 at 20:15
  • It is unnecessary to synchronize the package list when installing software. Most people will do this when updating the system instead. – user46 Aug 13 '12 at 20:16
  • 1
    It didn't work form me with Chromium + Gnash. – FR6 Nov 18 '12 at 4:41
0

Possible solution,install android on a chrooted environment. That way android can play flash because of the google chrome support and the flash plugin . Still a long way until android hits the raspberry pi.

Alternatives to Flash(If your only using it for video play back)

VLC(My favourite choice)

#Arch Linux
pacman -S vlc
#Debian
apt-get install vlc

Install this plugin . Then open VLC goto Tools > Preferences (Click All) > Interfaces > Main interface > Check Web and save. Restart and your done! OR

vlc -I http 

Lightroom

  • i installed vlc the other day as its my favourite media player and i wanted to test out a few avis. i didn't know about the chrome plugin though - that's probably the best solution to watching online flash movies (if it works well) - thanks. – mulllhausen Aug 13 '12 at 3:32
0

OS maemo/meego(based on debain) supports flash player on nokia n900(with ARM Cortex A8) microB Browser(based on Mozilla Firefox): http://natisbad.org/N900/n900-commented-hardware-specs.html

maemo download link: http://tablets-dev.nokia.com/ next link is needed to generate IMEI for N900 to download image files: *ttp://www.nokiaport.de/tacdatabase/index.php?s=imeitools&lng= i hope this info can help the raspberry pi community

thanks for reply if there is a chance to get it run on raspberry

  • I don't exactly understand your post. Can you clarify it a little? – hifkanotiks Sep 22 '12 at 11:52
-2

Are you using Google Chrome? I think that's short for Chronium. If so, I read that Google Chrome cannot run correctly on an ARM processor. Hope this helps. Try finding a different browser, use Epiphany or your pre-installed browser, or find another one using

sudo apt-get install

  • 2
    Hello and welcome. I think your command is missing something. Feel free to edit your answer. – Ghanima Dec 28 '15 at 16:06
  • 2
    apt-get install what exactly? You're missing the package to install. – Gene Dec 28 '15 at 17:52
  • The latest versions of Chromium (45 at time of writing) will only work on the RPi 2 Models without (I believe) any hardware acceleration, older Q&A in this SE community may refer to it working on the older Pis but that is an ancient version 22 that is not around now I think. – SlySven Dec 28 '15 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.