1

I have some 40" Samsung smart TV and my Raspberry Pi is connected through HDMI to the TV.

The screen is showing, but when I open the "monitor settings" in the Raspbian GUI it says "The following monitor is detected: ". Yes, it's empty! and the resolution is at 1824x984. I can't change anything.

Anyway, that isn't the problem. I can live with it, but when I start the emulationstation and want to play some games the screen is too big. It's going out of the screen at the top and I don't see the whole picture.

How do I fix this?

2

Entering /opt/vc/bin/tvservice -s at the command prompt will show the PI's current mode.

/opt/vc/bin/tvservice -m DMT or /opt/vc/bin/tvservice -m CEA should show what modes the TV supports.

settings can be configured in /boot/config.txt if you want to change any.

Look at http://elinux.org/R-Pi_ConfigurationFile which describes the settings in /boot/config.txt.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.