0

I purchased a TP-LINK TL-WN725N usb adaptor to connect to wifi, as I don't have an ethernet cable long enough to reach my router (on a different floor).

I've installed the drivers for my kernel version, and iwconfig shows wlan0 showing up. Trying to restart the network service (as per the tutorial I was following) however results an error along the lines of:

/etc/sbin/wpa_supplicant daemon failed to start
/etc/network/if-pre-up.d/wpa_supplicant exited with return code 1
failed to connect to wpa_supplicant --wpa_ctrl_open: no such file or directory

My /etc/network/interfaces file looks something like (aside from the default ethernet stuff):

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-ssid "******"
wpa-psk "******"

In my search for a solution I've frequently come across ideas such as 'install wicd', but alas until I get the wireless working I can't download anything to the device. Is it feasible to configure wifi through wpa_supplicant on rasbian with this particular adaptor, and if so how should I be setting up wpa_supplicant? I've seen a few different variations and I've yet to try a combination that has not given me this error.

  • Is it not possible for you to take the pi to your router, and use the ethernet cable to get the packages you need? – kolin May 7 '14 at 7:30
  • possible duplicate of WPA_GUI can't load wpa_supplicant – developius May 7 '14 at 16:33
  • @kolin that would involve also getting an hdmi monitor there, power cables, etc. I'll see if I can connect ethernet from my PC to the pi and share my internet connection that way. – Lucas Penney May 7 '14 at 20:34
  • 50m of ethernet costs about $10, and if your wifi reaches there, the 50m cable would too. – lenik May 8 '14 at 3:16
  • I think "get a very long ethernet cable" is not really a solution to a wireless adapter configuration issue. – Lucas Penney May 8 '14 at 3:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.