2

Pretty much just what the title is, does it? I want to know since I want to learn opengl using python...

  • 1
    Probably not installed by default but the PyOpenGL site claims experimental support from GLES 1 to 3.1 which covers the Pi. – user8894 May 11 '14 at 14:18
4

The python-opengl package isn't contained* in the Raspbian image by default, but you can easily install it:

sudo apt-get install python-opengl

* Here's the complete list of pre-installed packages in the current Raspbian image: http://pastebin.com/8W3i8bms

  • Thanks! You even saved me the trouble of looking for the command thanks so much! – androidmaster May 12 '14 at 21:36
2

You may use apt-cache command to find out what packages are available for your system.

In your particular case:

$ apt-cache search opengl | grep python
python-glitch - Python library for OpenGL graphics programming
python-gtkglext1 - GtkGLext python bindings
python-opengl - Python bindings to OpenGL           <-- here it is!!
python-pyside.qtopengl - Qt 4 OpenGL module - Python bindings
python-qt3-gl - Qt3 OpenGL bindings for Python
[...]
  • Wait so does this mean that it is installed? – androidmaster May 12 '14 at 21:37
  • No, this says it's available, not necessarily installed. – francis May 13 '14 at 10:49
1

n.st's solution works fine for python2. If you happen to have a python3 app you will want to

sudo apt-get install python3-opengl

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.