I am trying to compile Chromium for Raspberry PI. I am using an Ubuntu 10.10 installation, and have tried using Ubuntu 14.04 but all with the same result.

I followed all the steps in the link below.

How do I install Chrome OS?

Now everything works perfect up to the step for setting up the board. When I execute the command;

$ ./setup_board --board=raspberrypi


It seems I resolved the issue of the Thumb-1 hard float by calling:

sudo emerge mpfr mpc gmp

Now the compilation still fails but with a different error

configure:5879: x86_64-pc-linux-gnu-gcc -o conftest -O2 -pipe    -Wl,-O2 -Wl,--as-needed  conftest.c  -lisl >&5
conftest.c:10:25: fatal error: isl/version.h: No such file or directory
 #include <isl/version.h>
compilation terminated.

I understand that I am missing the ISL library. But when I try to do

emerge isl

It says

emerge: there are no ebuilds to satisfy "isl".

How can I retrieve the ISL library?

Issue Before

The build starts and works untill it is unable to compile gcc-libs-4.8.2-r11. When I look in the config.log I see the following errors;

gcc version 4.8.x-google 20140307 (prerelease) (GCC)
configure:3358: $? = 0
configure:3347:  /build/raspberrypi/tmp/portage/sys-libs/gcc-libs-4.8.2-r11/work/build/./gcc/xgcc -B/build/raspberrypi/tmp/portage/sys-libs/gcc-libs-4.8.2-r11/work/build/./gcc/ -B/usr/armv6j-cros-$
xgcc: error: unrecognized command line option '-V'
xgcc: fatal error: no input files
compilation terminated.


configure:3358: $? = 1
configure:3347:  /build/raspberrypi/tmp/portage/sys-libs/gcc-libs-4.8.2-r11/work/build/./gcc/xgcc -B/build/raspberrypi/tmp/portage/sys-libs/gcc-libs-4.8.2-r11/work/build/./gcc/ -B/usr/armv6j-cros-$
xgcc: error: unrecognized command line option '-qversion'
xgcc: fatal error: no input files
compilation terminated.
configure:3358: $? = 1


configure:3374:  /build/raspberrypi/tmp/portage/sys-libs/gcc-libs-4.8.2-r11/work/build/./gcc/xgcc -B/build/raspberrypi/tmp/portage/sys-libs/gcc-libs-4.8.2-r11/work/build/./gcc/ -B/usr/armv6j-cros-$
conftest.c: In function 'main':
conftest.c:12:1: sorry, unimplemented: Thumb-1 hard-float VFP ABI
configure:3377: $? = 1
configure:3565: checking for suffix of object files
error: cannot compute suffix of object files: cannot compile

What is causing these errors? How can I solve this problem, am I missing something? Do I need to compile on a different os? Can anybody point me in the right direction?

  • Please: do not cross-post (ref: your question on UL).
    – Ouki
    May 13, 2014 at 10:52
  • I edited that post saying it can be closed.
    – Thizzer
    May 13, 2014 at 11:16
  • I am sorry I am missing something. I am pretty sure Ubuntu 14.10 won't be out until October. And I am pretty sure emerge isn't a Debian-style package management utility as the ones in Ubuntu. How did you get it working on Ubuntu?
    – Marco Poli
    May 13, 2014 at 12:50
  • My bad, I meant Ubuntu 14.04 - Emerge is working inside the chroot created by the cros_sdk command.
    – Thizzer
    May 13, 2014 at 13:13
  • It seems to be building properly at the moment, when I resolve the issue and get it working on the Raspberry I will create a blog post.
    – Thizzer
    May 19, 2014 at 13:17

1 Answer 1


I don't have an exact answer, but would also like to see a recent version of Chrome running on the pi. After having a lot of issues building with Debian / Raspbian, I gave it a try with archlinux. I got a lot farther. I followed Moonman's instructions and was able to get it to compile, but it was missing libavcodec.so.54 and some of the files that ffmpeg generates. I had them, but newer versions, like libavcodec.so.56 which were not compatible.

I also found the PKGBUILDs repo also has a customized build file in the extra/chromium directory which is supposed to work for arm6, but I'm also having trouble getting this to compile.

My next steps are to understand more about moonman's build method, and possibly build the older version of ffmpeg so it would satisfy the library requirement.

Although this isn't a complete and working solution it's the best I've been able to find so far for building a recent version of chrome on the pi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.