2

I plugged in a regular Apple USB Keyboard, and it works nicely! Except.......

If I wish to press any Function keys, I need to hold down the Fn-Key and the function key to get it to talk to, SchismTracker, for instance.

What am I doing wrong, how do I make RPi simply recognize the keyboard as a regular keyboard without any craziness?

Bonus question - how do I map the "Fn"-key to be an Insert-key? :)

2

A quick search returns a blog entry which details how to make the function keys be the default. There is an option called fnmode in the Apple HID driver. You can test this by running:

echo 2 > /sys/module/hid_apple/parameters/fnmode

To make the change permanent, you need to edit /etc/modprobe.d/hid_apple.conf to have the following content:

options hid_apple fnmode=2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.