I just got a Raspberry Pi Model B. I wrote an image to an SD card using win32imagewriter and tried to boot my Pi with it. However, I got the following error repeated down the screen:

mmc0: error -110 whilst initialising sd card


I am using a Kingston MicroSDHC 8GB Class 4 card, and nothing is connected except the SD card, power and HDMI. I've tried all the available distros, but the error is the same.

What's going on? How can I get my Pi to boot?

  • Which image are you trying to use? It's important to have the newest possible so that you get kernel/firmware updated. There are some fixes for SD cards problems from time to time. Aug 20 '12 at 6:10
  • i tried all images at rpi downloads (i think these are newest images) and i get same error. About the firmware, is there a firmware flashed to a rom on rpi or is it the first partition on sd card?
    – kursat
    Aug 20 '12 at 22:50
  • Firmware files are on the SD card so they are inside the image. If you have the same error in all images then i doubt it's a firmware/kernel problem. Try another card. Aug 21 '12 at 6:15
  • thanks for the info Krzysztof, i used a Kingston 4GB SDHC Class 4 (SD4/4GB), now i can boot.
    – kursat
    Aug 23 '12 at 16:06

It sounds like you may have a bad card (I can't be sure from the info you have given, but it does sound like you have a compatible card - it may just be a problem with your particular card). You may want to check the list of compatible cards, and try another card from the list. You will also want to double check that the card holders pins are aligned and making good contact with the card. You should verify that you are supplying enough power to your pi.

  • i have read that list, my card is 6th at Kinston section. i am using it with sd adapter. could be the adapter, problem? i have checked the pins, by the way.
    – kursat
    Aug 19 '12 at 18:57
  • 1
    It is unlikely to be the adapter, but I can't rule it out. Just because your card is on the list does not mean all cards are created the same. You may just have gotten a bad card.The first thing to try would be another card (preferably a different model type than the one you have. How are you powering your Pi? Aug 19 '12 at 19:02
  • 1
    You could verify the write using a SHA1 hash Aug 19 '12 at 19:45
  • ok so ill try another card. i dont have a voltmeter right now, but red led is on and not blinking. ill let you now when i measure the voltage.
    – kursat
    Aug 19 '12 at 21:01
  • 1
    i got a Kingston 4GB SDHC Class 4 (SD4/4GB) and successfully boot it. Thanks Steve.
    – kursat
    Aug 20 '12 at 22:55

Write protect is set on the card! Unset it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.