10

Using the instructions in this answer I was able to get Bluetooth working with a small Asus branded USB receiver. I was able to see other Bluetooth devices in the area, but whenever I put my Motorola S10 headset in discoverable mode and ran the hcitool scan command, it would freeze up for a moment and then return with the error Inquiry failed: Connection timed out

I am guessing it is probably just missing the required bits to enable the A2DP and/or Headset profiles that the S10 is reporting back as supporting. Is there a package I can just apt-get and enjoy? For what it is worth, I installed bluetooth, bluez-utils and blueman through apt-get.

# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
...
Bus 001 Device 006: ID 0cf3:3005 Atheros Communications, Inc. AR3011 Bluetooth

# hcitool scan
Scanning ...
Inquiry failed: Connection timed out
  • 3
    You should try connecting the USB Bluetoorh dongle through a powered USB HUB. It might be a power issue. – Alex Cucu Aug 24 '12 at 11:56
  • 3
    I had a same problem, because I was using a powered USB HUB, plugging it in normally solved my problems. Maybe try that :) – DanFritz Sep 20 '12 at 22:43
  • 1
    Have you solved this? We're trying to clean up the site and this one has been dead for a while. – RPiAwesomeness Jan 11 '14 at 4:54
  • I haven't tried a powered hub (don't have one) but I did use a higher output (1A) 5V adapter and it seems to work. I wouldn't say the question is answered but available current does seem to be at to root of the issue. – Goyuix Jan 11 '14 at 15:40
  • Yeah, "get a stable high-current power supply instead of any old charger adapter you have lying around" seems to be the #1 solution to a lot of RasPi problems. – Matthias Urlichs Feb 5 '14 at 20:26
1

Although not officially considered "answered" by the OP, he did find a temporary solution, which I believe merits at least a stand-in answer until he finds a full solution. You can read the comment that I believe merits this stand-in here.

This answer can be removed as soon as the OP decides that he has completely solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.