3

I'm running OpenELEC 3.2.0 on Raspberry Pi
I'm trying to customize bashrc, the same way that we create/edit ~/.bashrc in individual GNU/Linux distributions. Which doesn't seem to be working on OpenELEC

I tried these paths:

/storage/.bashrc
/storage/.config/.bashrc
/storage/.config/bashrc
/storage/.config/shell.conf

But none of them seem to be working
(And /storage is the only place that we can customize things, since root partition is read-only)

5
# printenv 

shows that sh is the default shell, not bash! sh executes the /storage/.profile on ssh login.

here's my quick & dirty hack to switch to bash. make sure you have the /storage/.bashrc file and that it's error free.

# cat /storage/.profile
SHELL=/bin/bash
PATH=/storage/bin:$PATH
TERM=xterm-color
exec bash & source /storage/.bashrc
  • Thanks, that solved my problem. Just one more question: why bash functions aren't working? (I can move them into separate scripts of course, but I like to know why) – saeedgnu May 21 '14 at 21:08
  • @ilius Can you give an example? – Michael D. May 21 '14 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.