0

I bought WiFi dongle to my RPi and configured it. Brand is not so important, as I had access point from my Android phone and the internet worked on the RPi. However, when I try to connect to my home network, which is provided by D-Link DSL-2640B router, I cannot get internet working by any means. All I get is error "authentication request to the driver failed".

Tried all of the security options (none, WEP, WPA, WPA2), tried different settings for channels, tried different 802.11 modes... Nothing, RPi just won't connect.

Oh, and I tried of course lots of different options while manually editing the wpa_supplicant and networking/interfaces...

What's wrong with my D-Link router? I have Mac and Windows machines and Android phones connected to it with no problem at all.

  • you should check D-Link support area, that is definitely not here. – lenik May 25 '14 at 14:53
  • @lenik It's not off-topic. He is having an issue connecting his Raspberry Pi to a network that other devices connect to just fine (QUOTE: I have Mac and Windows machines and Android phones connected to it with no problem at all.). Thus, it isn't an issue with his router as you suggested (you should check D-Link support area), but an issue with the Raspberry Pi, rendering this issue on-topic. From the on-topic help page: For the most part this includes: ... Raspberry Pi Peripherals. – RPiAwesomeness May 27 '14 at 20:51
  • I have also just checked that this WiFi dongle is working fine with PC with Win7 and WinXP and connecting to my home network. So this is definitely issue with the Raspberry Pi. My WiFi dongle is: TP Link WN725N. I am still searching for a solution. – jacek May 28 '14 at 17:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.