2

I've logged all my progress here Raspberry Pi and the USB to TTL Serial Cable on Mac (unfinished).

screen /dev/cu.PL2303-000013FA 115200

Here's the errors that I'm getting

  1. It just hangs with a empty terminal screen.
  2. It errors / flashes Cannot open line '/dev/cu.PL2303-000013FA' for R/W: Resource busy and then lands on Sorry, could not find a PTY. then I get the command line back with a printed [screen is terminating] statement.
  3. If I run it with sudo ie sudo screen /dev/cu.PL2303-000013FA 115200 I get a completly different error /dev/cu.PL2303-000013FA: ioctl TIOCEXCL failed: Resource busy, then the blank terminal screen.

How do I resolve these issues, and get my raspberry pi working with the USB to TTL serial cable on OSX?

  • and your question is? – lenik May 25 '14 at 21:03
  • You shouldn't connect the 5v (red) cable. – Gerben May 26 '14 at 13:47
  • @lenik, errors imply I need assistance with said errors... – ThomasReggi May 27 '14 at 20:28
  • @Gerben I think it's completely irrelevant how I choose to power it. I'm not going through both power adapter and 5v. Why would that cause these errors? – ThomasReggi May 27 '14 at 20:29
  • @ThomasReggi Lenik does have a point. There is no explicit question here. While it is true that the errors do imply that you need help resolving said errors, you would be better off putting a simple one-line explicit question at the bottom of your question, something like How do I resolve these issues? or What is causing these errors?. – RPiAwesomeness May 27 '14 at 21:03
1

I came up with the same issue and I tried a lot of different solutions with no avail. Three different drivers, different versions of OS X and different terminal programs.

In the end the problem proved to be much more easily solved than I thought. Double check your cabling. Make sure you've not plugged the RX and TX cables inversely. As soon as figured out that my USB-to-Serial cable had the colours green and white swapped, going agains the documentation, all was solved.

I hope it is as simple as that to you too.

  • I'm pretty sure I've tried every cable combination. But I'll try this! Thanks! – ThomasReggi Jul 18 '14 at 15:34
  • I just went through every combination (including the black wire, which should be ground). I realized the resource busy issue was because I wasn't' exiting the screen command properly and the process stays alive, then when you try to connect again it's busy. – ThomasReggi Jun 27 '15 at 21:02
  • I just installed NOOBS 1.4.1 (and Raspbian) and within raspi-config under Advanced Options I enabled both SSH and Serial. I'm still getting a blank screen regardless the orientation of the white and green wires. – ThomasReggi Jun 27 '15 at 22:29
0

In reply to question #3, read https://stackoverflow.com/questions/8632586/macos-whats-the-difference-between-dev-tty-and-dev-cu

If you want to test your uart connector by itself, connect tx to rx. Then open your screen command. Every key you type should appear back (echod back). (note that it will only appear once, not twice). When you remove the wire, characters will stop appearing.

My final advice is to checkout the CP2102. For instance: http://www.amazon.com/KEDSUM%C2%AE-CP2102-Module-Download-Converter/dp/B009T2ZR6W

protected by goldilocks Aug 1 '15 at 13:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.