13

In anticipation of the MPEG2 hardware decode license being available, I bought an external DVD drive.

It works fine on my Windows 7 laptop. However, when I connect it to my raspberry pi, I'm unable to get the drive to open. All that happens is that the drive light flashes a couple of times and then there's a click inside like the lock has closed again. I suspect that there's a software issue blocking the opening, but I have tried to use both Raspbmc RC 4 and XBian 0.6.2

I am not powering the drive through the Pi.

Any ideas as to how to resolve this?

Edit

I used apt-get on Xbian to install "eject" and then managed to get the drive to eject using eject /dev/dvd. However, I now seem to be unable to mount the drive. Also, it would be nice if I could get the DVD drive to open by pressing the button.

Edit 2

Now that I have managed to insert a DVD, I rebooted and eject /dev/dvd no longer works because there IS no /dev/dvd. I'm afraid that I'm a little out of my depth here.

Relevant output from dmesg:

[    3.164519] usb 1-1.3: new high speed USB device number 5 using dwc_otg
[    3.294011] usb 1-1.3: New USB device found, idVendor=13fd, idProduct=1040
[    3.315175] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    3.334846] usb 1-1.3: Product: ODD-DVD SD-C2732
[    3.350829] usb 1-1.3: Manufacturer: Initio
[    3.370019] usb 1-1.3: SerialNumber: 0000000000000000W
[    3.380724] scsi0 : usb-storage 1-1.3:1.0
11
  • How are you powering it? Aug 26 '12 at 16:39
  • Powered directly from a kindle usb-wall adapter.
    – neuro
    Aug 26 '12 at 17:31
  • What is dmesg saying? Aug 26 '12 at 18:53
  • I think that I've pasted the relevant section of the output above.
    – neuro
    Aug 26 '12 at 19:21
  • Does eject /dev/scsi0 work? What does dmesg say during a button press? Aug 26 '12 at 19:24
2

The comments indicate that you are powering "it" from a kindle usb-wall adapter.

If by "it", you mean the RPi and the drive is plugged straight into the RPi, then the drive won't work.

This is because the USB ports on the RPi are only capable of passing through 100mA to the device.

Your choices are to use a powered USB hub so the drive is powered by the hub, or to do a hardware mod to get 5V to the drive without needing to go via the RPi

1
  • Sorry for the confusion. No, I was referring to the drive as "it". The drive is powered directly by the wall adapter.
    – neuro
    Sep 5 '12 at 8:47
1

Now that you can open the drive - to mount it, do this:

  1. in /media or /mnt or somewhere else create a directory, for example dvd
  2. to create it in e.g. /media you need to act as root: sudo mdir /media/dvd
  3. next, make it available to everybody, even you: sudo chmod 777 /media/dvd (you can restrict it more, once you get things working)
  4. the DVD drive is usually /dev/sr0 or if you have more drives it might be /dev/sr1 etc. so now mount it: sudo mount /dev/sr0 /media/dvd

This worked nicely for me.

This is far as it goes for mounting the drive.

Navigate to /media/dvd/ to see your files.

Hope this helped.

1
  • I hope that my edits meet with your agreement - if you really don't like them you may roll them back and edit your answer as you see fit.
    – SlySven
    Jan 19 '16 at 3:58
0

Check to see if you have /dev/sr0 (or any sr*, cd*, or dvd* devices). I notice you mentioned scsi and dvd, you might be looking for the wrong files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.