10

I'm running Arch, and when I shut down with the poweroff command (or with shutdown -h now) the 3 LEDs mentioned stay on. In addition, if I've plugged it into a screen, it displays

> POWER OFF
System halted

but doesn't actually power off - this text, along with the normal shutdown text, remains on the screen, and text I type on the keyboard still appears.

I assume that this means it isn't shutting down correctly, so what should I do to fix it? I've tried dd-ing over again, and the problem has persisted.

If it makes a difference, the last message printed before it claims to power off is Remounting Root Filesystem Read-only. I'm not sure if this is what it's supposed to do or not.

This is happening on a card where I've just dd'ed the .img I downloaded from the Raspberry Pi website, and it has persisted after copying the image again. It works fine in every other way that I've tried, and it boots up fine!

Sorry for only adding 1 tag - I couldn't find anything else appropriate!

EDIT: It seems to shutdown properly under the Debian image, so is this an arch problem rather than a raspberry problem?

8

It's fine

It's shutting down just fine. If you check the schematic, you'll see there is no power management. From USB in to the SoC is just copper (and a fuse), so the chip stays powered up even when it's shut down.

What do I do once I have run shutdown -h now?

Just remove the USB from the socket.

  • My problem is that the chip seems to still be able to do things - it's shut down the ssh daemon, but it still passes what I type through to the screen. This doesn't happen with the wheezy image. Is that just what Arch systems do? – DenverCoder8 Aug 31 '12 at 21:40
  • That doesn't really matter. As long as the file systems are not writeable, you can yank the power cord. Your Raspberry Pi has already told you that (Remounting Root Filesystem Read-only), so your data's safe. – scruss Sep 1 '12 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.