9

I've flashed a 2GB SD card with the Raspbian wheezy image from http://www.raspberrypi.org/downloads, which boots up fine, but after typing "startx", I'm facing an empty desktop with the raspberry logo; nothing further happens. The pointer moves, I can switch to other TTYs with Ctrl+Alt+Fx, but that's it. No desktop icons or other GUI elements.

Is this supposed to happen? Do I need to manually set up a light desktop environment, or is there something else I need to do?

(I've tried the Arch Linux image too, and it too boots up fine to the command prompt. I don't seem to have hardware or power problems.)

df -h output:

enter image description here

  • What are you using as a monitor and how is it connected to your Pi? – Steve Robillard Sep 1 '12 at 9:26
  • I'm using a 32 inch TV ("HD-Ready", 1366x768) connected via HDMI. Do you suspect that it's incorrectly set as the second display? – rasper Sep 1 '12 at 10:17
  • 5
    Is anything getting started? Could you have a look through the output from startx, ~/.xsession-errors and /var/log/Xorg.0.log and see if something fails. pstree -ph -u pi (while the X session is running) output may also be informative. – XTL Sep 3 '12 at 6:37
  • 1
    Does the whitespace around the raspberry reach to the edge of the screen? – Steve Robillard Sep 4 '12 at 18:47
  • 2
    Make sure you have a window manager/desktop environment set to execute in ~/.xinitrc. For example: exec openbox – Munkeh Sep 22 '12 at 11:42
2

To have a complete desktop environment (X + window manager + decorator) you should type:

/etc/init.d/lightdm start

If you want your Raspberry Pi to boot directly into lightdm, run:

sudo raspi-config

and set the second last option boot_behaviour to yes.

  • 1
    startx should disguise all this. – Alex Chamberlain Sep 26 '12 at 21:20
  • /etc/init.d/{gdm|xdm|lightdm} start has always been the "right way" to launch a desktop environment. startx always launched only X as far as I can remember... – Avio Sep 26 '12 at 21:22
  • 1
    @Avio X then starts the session of your WM from what you've put your .xinitrx file. – Jivings Sep 26 '12 at 23:23
  • Ok, sorry, didn't knew that. – Avio Sep 27 '12 at 10:27
0

I had this same problem, thinking it was something to do with the SD card or some random weird bug. I did fool around with formatting the card, but what I think did it was that I went into the raspi-config and set things like the clock, locale, and language up.

There are only 1 or 2 posts like this on the net, so either it's not a common problem, or it's a "der" moment. I'm new to Linux, so I guess the latter for me.

Once I set things up in raspi-config, this time I got the GUI I was expecting.

These videos gave me some food for thought to try those settings (mostly part 2):

Raspberry Pi running Raspbian - Part 1 - First boot and Raspi-config

Raspberry Pi running Raspbian - Part 2 - Booting to LXDE

0

The same thing happened to me. I was stumped but then went into my advance options in sudo raspi-config and my memory was split to 512. I switched back to 256... now everything is perfect.

  • Hi geiovanni, Welcome to SE.Raspberry Pi. :-) Can you edit you answer to provide a few more details? Are you saying that reducing the memory allocated to the GPU was 512, and then when you reduced the GPU memory to 256, the desktop appeared correctly? If you could provide screenshots to support your answer, that would be great. – Greenonline Sep 19 '15 at 15:02
0

It's basically the local desktop for the user.

You may need to add the content for user desktop and thereafter it will display the information.

The pi user will have default desktop icons come along with package.

0

I accidently did this before as well. I had used the lite version of raspbian rather than the full version with desktop mode. As you said you have a 2GB micro SD card, I would personally think it would be wise to get one with 8GB or higher and burn the desktop image to that SD card.

-5

Boot under pi user, NOT root..

  • 4
    From the screenshot it does look as if rasper is using the Pi user. – Jivings Nov 28 '12 at 21:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.