1

When I plug in my Pi, the red power light comes on, but no other lights blink at all, nothing appears on screen, no network activity, etc. The activity light glows faintly, but never turns off.

What I have tried:

  • Two different SD cards, one brand new
  • Two different power supplies, confirmed with a voltmeter to be supplying 4.9ish volts
  • Both NOOBS and Raspbian; both downloads had the correct hash. For Raspbian, I tried writing the SD card using this method, and using Cygwin to run a dd command. Both methods appeared to work, and Windows Explorer showed all the files that are supposed to be there.
  • Everything is unplugged from the Pi except the power supply and the SD card
  • The SD card slot looks alright to me, although I would love to see a picture to compare it to. I have tried holding the SD card in place to make sure it's in contact with the slot.

Is there anything I haven't tried, and if there is a hardware problem with the Pi, is there any way to diagnose what part is broken?

  • On whatever machine you set up the SD card verify that the partitions exist (for Raspbian a small FAT and a larger Linux partition) Check files in FAT. Other troublshooting on elinux.org/R-Pi_Troubleshooting – Milliways Jun 1 '14 at 1:07
3

From the R-Pi Troubleshooting:

Red power LED is on, green LED does not flash, nothing on display
Note: A faintly glowing steady green LED means no boot code has ever been executed, as almost the first thing the boot code does is to turn the faint glow off! When flashing/blinking the green LED should be as bright as the red LED.

At this point, I can say you have to check your SD card and your boot code.

Below this line it's not an answer but a way to check your SD card or image sanity.

Sometimes I use Qemu to test RPi images. You can check your SD card image with qemu whether if it can boot or not. Your qemu command should look like this for any Linux distro. By the way you have to install qemu-system-arm to get work on Ubuntu. (Run sudo apt-get install qemu-system-arm to install.)

Then you must have qemu-kernel for arm6, download it from qemu-rpi-kernel (original link not working anymore: http://www.xecdesign.com/downloads/linux-qemu/kernel-qemu).

qemu-system-arm -kernel kernel-qemu -cpu arm1176 -m 256 -M versatilepb -no-reboot -hda [your_image_file.img] -append "root=/dev/sda2"

(You have to replace root=/dev/sda2 field as your root partition.)

Another blog entry which can help you to test your image to emulate: Emulating Arch Linux For the Raspberry Pi in QEMU.

If your image does not boot correctly at Qemu emulator, you should consider the problem should be SD card or image that you tried.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.