1

This is an odd issue that there have been quite a bit of discussion about even on this forum. Possible suggested issues range from insufficient power to bad internal hardware design of the pi.

When Edimax EW-7811UN usb adapter is plugged in pi reboots instantly.

I have ruled out the power supply by using 2 different ones for testing (1.5A wall plug and 2A open frame psu). I tried 3 different raspberry pi's bought at different times all with same issue. I also tried different sd cards, and even operating systems (Raspbian, RaspBMC). I ran rpi-update on a clean Raspbian OS install (NOOBS 1.3.7, NOOBS LITE 1.3.5).

I measured the voltage at test points and got around 4.5V when booted.

The only thing that seems to work is strangely plugging the usb adapter via an old usb extension cable I had lying around (it could even be rated for usb 1.1 use if that matters).

Why would a simple usb extension solve the problem? It almost seems like pi resets purposely as soon as it detects a device is connected.

  • I've had this happen using raspbian with my USB WIFI and my bluetooth USB keyboard. – PhillyNJ Jun 4 '14 at 19:56
  • I tried with Intatech bluetooth adapter but no reboot, I guess it depends on the design of the wireless usb device. – DominicM Jun 4 '14 at 20:45
  • I wasnt using a hub... direct to the USB. Perhaps a power issue. – PhillyNJ Jun 4 '14 at 21:44
  • In your case maybe, in my case it could not be the issue as the extension cable doesn't make a difference power wise. – DominicM Jun 4 '14 at 22:16
  • I personally think its in the design of the RPi. The same goes for using a SD Card to boot and host the OS. I have had server SD cards crap out on me. Horrible design. I digress.... – PhillyNJ Jun 4 '14 at 22:19
1

Simple. You're drawing too much power. In at least the newer versions of the Pi, 2.0 revision and some 1.0, the USB polyfuses have been removed. This is expected behaviour, and you really can't do anything about it.

Basic answer:

Hotplugging a USB device will cause a spike in current demand, thus causing the reboot. If you want to hotplug, you will have to use an external powered hub (powered being key, otherwise it just draws from the Pi, causing even more issues,) or plug the device in prior to boot.

More info:

You can technically change this, but it requires hardware modification like bypassing the F3 polyfuse, replacing capacitors, replacing 0R resistors at the USB hub, etc. However, these aren't suggested as they would obviously void your warranty and can easily fry your Pi if done incorrectly, not to mention changing the core way the Pi works.

Links (You mentioned you had read the discussion about this, have you seen all of these?):

Old official forum post started back in 2012
Basically a duplicate - has 3 more posts than the one above
Specifically states the issue as a WiFi dongle
Raspberry Pi reboots on plugging in a USB device - From this site.

  • How does this explain the fact that using a simple USB extension cable resolve the problem? – DominicM Jun 4 '14 at 22:23
  • @DominicM Is the cord powered in any way other than the Pi's USB port? – RPiAwesomeness Jun 5 '14 at 2:57
  • No, it is just an extension. The plastic is transparent and I see no circuitry inside the usb connector either. – DominicM Jun 5 '14 at 13:44
  • @DominicM Then I don't know. Perhaps the Pi has just enough time to recognize the device prior to the device requesting the power that the Pi is ready for the spike in requested power. Not certain though. – RPiAwesomeness Jun 5 '14 at 20:34
1

If the "measured voltage at test points and got around 4.5V when booted" then you are lucky the Pi works at all. This is below the minimum rated voltage.

If it is this low when booted then the transient would be even lower during startup.

  • You are right, it was an issue with a voltage drop somewhere in my prototype board, not sure why/where exactly but even with direct connection to 5v/gnd and voltage reading of 4.96V the issue is still the same. – DominicM Jun 5 '14 at 13:46

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.