2

I bought a D-Link DWA-131 USB Wifi adapter as it was supposed to work straight out of the box. The device shows up OK in the USB list (lsusb). I've added the wlanX sections to the /etc/network/interfaces file. But there seems to be a problem connecting to my network, specifically, trouble with the mac address.

The reported mac address for the DWA-131 dongle changes depending on how it's plugged in.

If it's plugged directly into the pi's USB socket, the ifconfig shows the correct mac address, the light never flashes and the device can't connect to the router, even when close and with a clear line of sight.

If it's plugged into the powered hub, ifconfig shows a mac address of ff:ff:ff:ff:ff:ff, the light flashes and the device can see the router, the router can also see the device, the router sees the device's mac address as ff:...:ff. The SSID is visible. The dhcp requests never make it to the dhcp server (an Ubuntu box), the server never responds (obviously) and the router only shows packets coming from the dongle and never to it.

The mac address looks wrong to me when using the hub. Does anyone know how to get this thing to use the correct mac address? I've tried putting a "hwaddress ether " into my interfaces file but that was just ignored.

I'm using the latest wheezy debian image for the SD card.

  • What commands do you run after inserting the dongle? – Alex Chamberlain Sep 12 '12 at 6:15
  • @AlexChamberlain: sudo ifup wlan1 which outputs some info and several DHCPREQUESTs and then completes without connecting. – Skizz Sep 12 '12 at 8:30
  • I don't think you're connecting to the access point... There's a guide somewhere. – Alex Chamberlain Sep 12 '12 at 8:31
  • Is this helpful? ghacks.net/2009/04/14/… – Alex Chamberlain Sep 12 '12 at 8:37
  • @AlexChamberlain: Good article, but doesn't help - I've already done the steps it suggests. I think the main issue is the mac address. It shouldn't be the broadcast address. – Skizz Sep 12 '12 at 8:48
0

The issue in the end was nothing to do with the configuration of the WiFi adapter. Plugging the adapter into one USB port on the Pi directly and a keyboard into the other, the network connected successfully and everything worked as required.

I was then able to update the software on the Pi!

The Powered USB hub, however, is the source of all the problems I had been having. This is the sequence of steps that I need to take in order to get the hub, the dongle and the mouse to work.

  1. The hub is plugged into one of the Pi's USB ports and the keyboard into the other.
  2. The mouse and wi-fi adapter are plugged into the hub, the hub is not switched on.
  3. Switch on the Pi and log in.
  4. Switch on the Hub.
  5. Do an 'ifup' to connect to network.

Doing this even allows the mouse to work.

  • As of Feb '13 the Raspbian build is much more friendly to my devices. I can plug the WiFi and Hub into the Pi and everything else into the hub and it all works! – Skizz Feb 4 '13 at 9:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.