4

I've setup Bluetooth on my RaspPi and attempted to connect to my BlueSmirf from Sparkfun.

I can send text to my BlueSmirf from the RaspberryPi using:

echo "Testing" > /dev/rfcomm0

Now the red led on my BlueSmirf indicates its not paired with a device, only when I use cat /dev/rfcomm0 the raspberryPi will start a Pairing session with the BlueSmirf (and the led turns green).

I now can send and receive text from both sides, the problem is that I manually need to invoke cat /dev/rfcomm0. I would like that the RaspberryPi looks for my BlueSmirf at startup and starts a pairing session automatically.

Thanks!

3

Ha found the solution, first and all in the rfcomm.conf set the bind option to no. this solves a lot of problems. Next you use the rfcomm command to start a connection.

For example: rfcomm connect 0 Will open a connection using the configuration of rfcomm0. You can send this to the background, so its always connected using the following command:

rfcomm connect 0 &> /dev/null 2> /dev/null &

To close a connection you use the following command rfcomm release 0

1

I've seen a new Bluetooth solution for our Raspis. There are 2 versions, you can find them here and here. Have you tried it?

I own a pub and I was looking for a contest using Bluetooth and mobile phones. I think this PRO solution can be great to manage the contest with my Raspi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.