I installed OpenCV 2.3.1 in my Raspberry Pi (Debian Wheezy) following this tutorial.

But I can't take video using my USB webcam. Gstreamer shows this error:

OpenCV Error: Unsupported format or combination of formats (Gstreamer Opencv backend doesn't support this codec acutally.) in CvVideoWriter_GStreamer::open, file /home/pi/OpenCV-2.3.1/modules/highgui/src/cap_gstreamer.cpp, line 483 terminate called after throwing an instance of 'cv::Exception' what(): /home/pi/OpenCV-2.3.1/modules/highgui/src/cap_gstreamer.cpp:483: error: (-210) Gstreamer Opencv backend doesn't support this codec acutally. in function CvVideoWriter_GStreamer::open Aborted

What can I do next?

  • What webcam are you using? Sep 18, 2012 at 7:07
  • Hi, I am using e-CAM30_USB module. I can take images with this camera. I am using raspberry pi with Debian Wheezy. FFMPEG is ON. Still I am facing problem. Please help me.
    – sumith
    Sep 18, 2012 at 7:25

2 Answers 2


The gstreamer tells you the stream is unsupported. FFMPEG is on like you said.

I had a look at the camera specifications- it comes out of laptop and is intended to work with Microsoft Windows mostly and not really supported for Linux but they say it will work on Redhat 2.+

That camera returns video in on of these codecs


The still pictures is a standard JPG encoded by the MJPEG encoder, that's why you can see it. I am sure gstreamer supports MJPEG and not sure about YUV2. But! It is possible that the MJPEG implementation for ARM (Pi) architecture could still not be supported.

Possibly gstreamer needs to ask the camera for MJPEG directly or something else needs to ask for it. I doubt YUY2 will work any good on the Pi.(At least it is not listed in any supported codecs - but MJPG is)

It is possible that you should use something other than gstreamer. Take a look here. or at this post.


OP resolved the problem by using image 2012-09-18-wheezy-raspbian and installing OpenCV 2.4.2 using this extensive and long guide.

  • What do you guys mean by FFMPEG is on/off? Sep 18, 2012 at 14:11
  • 1
    The camera has a setting somewhere to choose the video format. YUY2 is uncompressed, faster and better quality. Enabling this MPEG feature most likley tries to transport the video using MJPEG(which are series of JPG files not really a sophisticated video format) So maybe using gstreamer is not the solution!
    – Piotr Kula
    Sep 18, 2012 at 14:22
  • Hi, I have much pleasure to inform you, the problem is over. What I done is, 1. I installed new image 2012-09-18-wheezy-raspbian.img on my raspberry pi. Ref: elinux.org/RPi_Easy_SD_Card_Setup 2. Then installed OpenCV 2.4.2 following the site Ref: mitchtech.net/raspberry-pi-opencv Now I can take video with logitech hd720p usb webcam. Thanks to your support. But I am interested to know why this task shows problems in opencv 2.3.1.
    – sumith
    Sep 29, 2012 at 5:51
  • Hi,Mr ppumkin, I tried to take images with econ Ecam-32 web cam using mjpg-streamer as you said but still I got bad images while logitech cam is working well. Ref: tanzilli.com/video_streaming.Can we do something else?
    – sumith
    Oct 8, 2012 at 11:20

Raspberry pi is working with e-con ECAM 32 web cam now. I changed the voltage regulator which delivering 3.3v to camera , and connected TPS736xx voltage regulator from Texas instruments and now camera taking 320x240 pixel images and video...

Thank you very much for you supports...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.